POJ - 1971 C - Parallelogram Counting

9 篇文章 0 订阅

C - Parallelogram Counting

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

5

6

 

 

 

#include<stdio.h>

#include<string.h>

#include<cstdio>

#include<map>

#include<iostream>

#include<algorithm>

#define M 10000000

using namespace std;

struct hanshu

{

    int x,y;

}a[M];

struct zhi

{

    int x,y;

}b[M];

int cmp(struct zhi q,struct zhi w)

{

    if(q.x!=w.x)

    {

        return q.x<w.x;

    }

    else

    {

        return q.y<w.y;

    }

}

int main()

{

    int T;

    scanf("%d",&T);

    while(T--)

    {

        int t,i,j;

        scanf("%d",&t);

        for(i=0;i<t;i++)

        {

            scanf("%d%d",&a[i].x,&a[i].y);

        }

        int k=0;

        for(i=0;i<t;i++)

        {

            for(j=i+1;j<t;j++)

            {

                int x=(a[i].x+a[j].x);

                int y=(a[i].y+a[j].y);

                b[k].x=x,b[k].y=y;

                k++;

            }

        }

        sort(b,b+k,cmp);

        int sum=0,c=1;

        int x1=b[0].x,y1=b[0].y;

        for(i=1;i<k;i++)

        {

            if(b[i].x==x1&&b[i].y==y1)

            {

                c++;

            }

            else

            {

                sum=sum+(c)*(c-1)/2;

                x1=b[i].x,y1=b[i].y;

                c=1;

            }

        }

        if(c!=1)

        {

            sum=sum+(c)*(c-1)/2;

        }

        printf("%d\n",sum);

    }

    return 0;

}

 

 

判断能组成多少个平行四边形。

这题利用平行四边形的性质中点到对角线的距离相等来求然后排序。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值