Bone Collector

Bone Collector

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2[sup]31[/sup]).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

题目大意

输入第一行为一个整数表示T组测试样例。
每组测试样例有三行:
第一行包含两个整数N, V, (N <= 1000, V <= 1000),代表骨头的数量和他的包的体积。
第二行包含N个整数代表每根骨头的值。
第三行包含N个整数,代表每根骨头的体积。
现在需要求怎么装骨头能时所装骨头的值最大。输出这个最大值即可。

解题思路

这是一道01背包模板题,有关01背包的详细讲解链接是
这里写链接内容

代码
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int weight[1005]; //各个物品的体积。
int value[1005];//各个物品的价值。
int f[1005]; //f[j]意味容积j时的最优解。
int main()
{
    int T,N,V;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&N,&V);
        for(int i=0;i<N;i++)
        {
            scanf("%d",&value[i]);
        }
        for(int i=0;i<N;i++)
        {
            scanf("%d",&weight[i]);
        }
        memset(f,0,sizeof(f)); //先把f[]初始化为0。
        for(int i=0;i<N;i++)   //找出容积为 j 时向背包里装物品的最优解
        {
            for(int j=V;j>=weight[i];j--)
            {
                f[j]=max(f[j],f[j-weight[i]]+value[i]);
            }
        }                 //求最优解结束
        cout << f[V] << endl;
        }
        return 0;
}

是不是很容易懂啊(* ̄rǒ ̄)。客官 留下小心心再走。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值