[UVA - 10285]Longest Run on a Snowboard

Longest Run on a Snowboard

Michael likes snowboarding. That’s not very surprising, since snowboarding is really great. The bad
thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when
you’ve reached the bottom of the hill you have to walk up again or wait for the ski-lift.
Michael would like to know how long the longest run in an area is. That area is given by a grid of
numbers, defining the heights at those points. Look at this example:
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
One can slide down from one point to a connected other one if and only if the height decreases. One
point is connected to another if it’s at left, at right, above or below it. In the sample map, a possible
slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-. . . -3-2-1, it would
be a much longer run. In fact, it’s the longest possible.
Input
The first line contains the number of test cases N . Each test case starts with a line containing the
name (it’s a single string), the number of rows R and the number of columns C. After that follow R
lines with C numbers each, defining the heights. R and C won’t be bigger than 100, N not bigger than
15 and the heights are always in the range from 0 to 100.
Output
For each test case, print a line containing the name of the area, a colon, a space and the length of the
longest run one can slide down in that area.
Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
Feldberg: 7
Spiral: 25

记忆化搜索

  1. 看到这个题,很容易想到搜索,但是注意,如果直接从每个点开始搜,将会有许多点都重复走过,比如第二个样例中22这个点,从25开始的时候会搜到它,到23的时候又搜一遍,这样复杂度将会变得非常大。所以我们用记忆化搜索来优化,避免走大量重复的路径。
  2. 用dp[i][j]表示从(i, j)这个点出发可以走的最长距离,第一次走过一个点,赋值为1,后面再更新。
  3. 我们可以遍历r * c的这张图,然后递归找与它相邻的点中比它低的,如果有相邻点的值+ 1比它的值大,那么更新这个点的dp[i][j]。
  4. 这样我们每个点就可以最多只走一遍了。

下面是代码:

#include<bits/stdc++.h>
using namespace std;
const int MAXN = 150;
char name[MAXN];
int r, c;
int a[MAXN][MAXN], dp[MAXN][MAXN];
int dx[] = {0, 1, -1, 0};
int dy[] = {-1, 0, 0, 1};
int dfs(int x, int y)
{
	int &ans = dp[x][y];      //ans等价于dp[x][y] 
	if(ans)return ans;       //判断ans是否为0得知这个点是否走过,保证每个点只走一遍 
	ans = 1;
	for(int i = 0; i < 4; i++)
	{
		int nx = x + dx[i];
		int ny = y + dy[i];
		if(nx > r || nx < 1 || ny > c || ny < 1 || a[nx][ny] >= a[x][y])
		continue; 
		dfs(nx, ny);
		ans = max(dp[nx][ny] + 1, ans); 
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		memset(dp, 0, sizeof(dp));        //记得清空数组 
		scanf("%s %d %d", name, &r, &c);
		for(int i = 1; i <= r; i++)
		for(int j = 1; j <= c; j++)
		    scanf("%d", &a[i][j]);
		int maxn = 0;
		for(int i = 1; i <= r; i++)
		for(int j = 1; j <= c; j++)
			maxn = max(maxn, dfs(i, j));
		printf("%s: %d\n", name, maxn);
	}
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值