前缀和——Stripe

Stripe

题面翻译

给定一整数n,下面有n个数a[i],求将该数列分割成两个非空数列且两个数列内数字的和相等的方案数
1<=n<=10^5
a[i]的绝对值不大于10000

Translated by 稀神探女

题目描述

Once Bob took a paper stripe of $ n $ squares (the height of the stripe is 1 square). In each square he wrote an integer number, possibly negative. He became interested in how many ways exist to cut this stripe into two pieces so that the sum of numbers from one piece is equal to the sum of numbers from the other piece, and each piece contains positive integer amount of squares. Would you help Bob solve this problem?

输入格式

The first input line contains integer $ n $ ( $ 1<=n<=10^{5} $ ) — amount of squares in the stripe. The second line contains $ n $ space-separated numbers — they are the numbers written in the squares of the stripe. These numbers are integer and do not exceed 10000 in absolute value.

输出格式

Output the amount of ways to cut the stripe into two non-empty pieces so that the sum of numbers from one piece is equal to the sum of numbers from the other piece. Don’t forget that it’s allowed to cut the stripe along the squares’ borders only.

样例 #1

样例输入 #1

9
1 5 -6 7 9 -16 0 -2 2

样例输出 #1

3

样例 #2

样例输入 #2

3
1 1 1

样例输出 #2

0

样例 #3

样例输入 #3

2
0 0

样例输出 #3

1

思路

由于本道题要求全部选上,我们只需枚举端点即可(前缀和)

代码

#include<iostream>
#include<algorithm>

using namespace std;

const int N = 1e5+10;

int w[N],s[N];
int n;

int main(){
    cin>>n;
    
    for(int i=1;i<=n;i++){
        cin>>w[i];
        s[i]=s[i-1]+w[i];
    }
    
    int ans=0;
    for(int i=1;i<=n-1;i++){
        if(s[i]-s[0]==s[n]-s[i]){
            ans++;
        }
    }
    
    cout<<ans;
    
    return 0;
}
  • 6
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值