模拟+字符串——Flag

Flag

题面翻译

题目描述

根据一项新的 ISO 标准,每一个国家的国旗应该是一个 n × m n\times m n×m 的格子场,其中每个格子最多有 10 10 10 种不同的颜色。并且国旗应该有条纹:旗帜的每一行应包含相同颜色的方块,相邻的行的颜色应该是不同的。Berland 政府要求你找出他们的国旗是否符合新的 ISO 标准。

输入格式

输入的第一行包含数 n n n m m m,其中 n n n 为行数, m m m 为列数。

接下来是对旗的描述:以下 n n n 行中的每一行包含 m m m 个字符。每个字符是 0 0 0 9 9 9 之间的数字,代表相应正方形的颜色。

输出格式

如果国旗符合标准就输出 YES,否则输出 NO

题目描述

According to a new ISO standard, a flag of every country should have a chequered field $ n×m $ , each square should be of one of 10 colours, and the flag should be «striped»: each horizontal row of the flag should contain squares of the same colour, and the colours of adjacent horizontal rows should be different. Berland’s government asked you to find out whether their flag meets the new ISO standard.

输入格式

The first line of the input contains numbers $ n $ and $ m $ ( $ 1<=n,m<=100 $ ), $ n $ — the amount of rows, $ m $ — the amount of columns on the flag of Berland. Then there follows the description of the flag: each of the following $ n $ lines contain $ m $ characters. Each character is a digit between 0 and 9, and stands for the colour of the corresponding square.

输出格式

Output YES, if the flag meets the new ISO standard, and NO otherwise.

样例 #1

样例输入 #1

3 3
000
111
222

样例输出 #1

YES

样例 #2

样例输入 #2

3 3
000
000
111

样例输出 #2

NO

样例 #3

样例输入 #3

3 3
000
111
002

样例输出 #3

NO

思路

本道题就两个规则:上下相邻不能相等,左右不能出现不一样的。

代码

#include<iostream>
#include<cstring>

using namespace std;

const int N = 110;

string a[N],b,cnt;
int s[10000];
int n,m;

int main(){
    cin>>n>>m;
    
    for(int i=1;i<=n;i++){
        cin>>b;
        a[i]=b;
        for(int j=0;j<b.size();j++){
            s[b[j]]++;
        }
        for(int j=0;j<b.size();j++){
            if(s[b[j]]!=m){
                puts("NO");
                return 0;
            }
        }
        
        memset(s,0,sizeof s);
        
        if(i!=1){
            if(a[i]==a[i-1]){
                puts("NO");
                return 0;
            }
        }
    }
    
    puts("YES");
    
    return 0;
}
  • 22
    点赞
  • 20
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
Levenshtein Distance算法是一种常见的字符串相似度算法,也被称为编辑距离算法。其主要思想是通过计算两个字符串之间的编辑距离来确定它们的相似程度。 编辑距离指的是将一个字符串转换成另一个字符串所需的最少操作次数,其中每次操作可以是插入、删除或替换一个字符。例如,将字符串“kitten”转换成字符串“sitting”需要进行3次操作,即将“k”替换为“s”,将“e”替换为“i”,将“n”替换为“g”。 Levenshtein Distance算法的实现一般使用动态规划的方法,通过填充一个二维矩阵来计算两个字符串之间的编辑距离。具体实现过程可以参考以下伪代码: ``` function LevenshteinDistance(s1, s2): m = length(s1) n = length(s2) d = new matrix(m+1, n+1) for i from 0 to m: d[i, 0] = i for j from 0 to n: d[0, j] = j for j from 1 to n: for i from 1 to m: if s1[i] == s2[j]: cost = 0 else: cost = 1 d[i, j] = min(d[i-1, j]+1, d[i, j-1]+1, d[i-1, j-1]+cost) return d[m, n] ``` 在以上代码中,变量s1和s2分别表示两个待比较的字符串,m和n分别表示它们的长度,矩阵d用于存储编辑距离的计算结果。首先,将矩阵d的第一行和第一列分别初始化为0到n和0到m的整数。然后,对于每个(i, j)位置,如果s1[i]等于s2[j],则将cost设为0,否则设为1。最后,根据递推公式d[i, j] = min(d[i-1, j]+1, d[i, j-1]+1, d[i-1, j-1]+cost)来填充矩阵d,并返回d[m, n]作为编辑距离的结果。 Levenshtein Distance算法的时间复杂度为O(m*n),其中m和n分别为两个字符串的长度。在实际应用中,该算法可用于拼写检查、数据去重等场景。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值