[USACO07OPEN] Cheapest Palindrome G(区间dp)

[USACO07OPEN] Cheapest Palindrome G

题面翻译

题目描述

给定一个由 n n n 个不同的小写字母构成的长 m m m 的字符串 s s s。可以通过 s \bm{s} s 的任意位置增减字母将 s s s 改为回文串。增减字母的花费不同,求最小花费。

输入格式

1 1 1 行是两个整数 n , m n,m n,m

2 2 2 行是字符串 s s s

接下 n n n 行,每行一个字符 c c c 和两个整数 x , y x,y x,y,表示添加一个 c c c 的花费为 x x x,删除一个 c c c 的花费为 y y y

输出格式

只有 1 1 1 行,表示最小花费。

数据范围

对于 100 % 100\% 100% 的数据, 1 ≤ m ≤ 2 × 1 0 3 , 1 ≤ n ≤ 26 , 0 ≤ x , y ≤ 1 0 4 1\le m\le2\times10^3,1\le n\le 26,0\le x,y\le 10^4 1m2×103,1n26,0x,y104

b y   @ \mathrm{by\ @} by @ F i s h _ K n o w _ F o r e v e r \mathrm{Fish\_Know\_Forever} Fish_Know_Forever

题目描述

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).

FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

输入格式

Line 1: Two space-separated integers: N and M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

输出格式

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

样例 #1

样例输入 #1

3 4
abcb
a 1000 1100
b 350 700
c 200 800

样例输出 #1

900

提示

If we insert an “a” on the end to get “abcba”, the cost would be 1000. If we delete the “a” on the beginning to get “bcb”, the cost would be 1100. If we insert “bcb” at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

思路

这道题是在连续的区间进行修改,而且求最小花费,且数据规模不大,此时我们就用区间dp。这道题利用区间dp来调整出回文串,区间dp只要我们发现它不满足回文串,我们可以直接看是修改了还是删了,看看它们哪个价值更低,改完我们默认它就是回文串了。
也就是:
在这里插入图片描述

代码

//f[i][j]表示区间i,j的最小费用方案

#include<iostream>
#include<cstring>

using namespace std;

const int N = 2e3+10;

int f[N][N];
char a[N];
int add[N],del[N];
int n,m;

int main(){
    cin>>n>>m;
    
    cin>>(a+1);
    
    for(int i=1;i<=n;i++){
        char aa;
        int b,c;
        cin>>aa>>b>>c;
        add[aa]=b,del[aa]=c;
    }
    
    memset(f,0x3f,sizeof f);
    
    for(int i=1;i<=m;i++){
        f[i][i]=0;
        for(int j=1;j<i;j++){
            if(a[i]==a[j]){
                f[i][j]=0;
            }
        }
    }
    
    
    for(int len=1;len<=m;len++){
        for(int l=1;l+len-1<=m;l++){
            int r=l+len-1;
            if(a[l]==a[r]){
                f[l][r]=min(f[l][r],f[l+1][r-1]);
            }else{
                f[l][r]=min(f[l+1][r]+min(add[a[l]],del[a[l]]),f[l][r-1]+min(add[a[r]],del[a[r]]));
            }
        }
    }
    
    
    cout<<f[1][m];
    
    return 0;
}
  • 21
    点赞
  • 20
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值