[USACO06FEB] Treats for the Cows G/S(区间dp)

[USACO06FEB] Treats for the Cows G/S

题目描述

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:The treats are numbered 1…N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.Like fine wines and delicious cheeses, the treats improve with age and command greater prices.The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

约翰经常给产奶量高的奶牛发特殊津贴,于是很快奶牛们拥有了大笔不知该怎么花的钱。为此,约翰购置了 N N N 1 ≤ N ≤ 2000 1 \leq N \leq 2000 1N2000) 份美味的零食来卖给奶牛们。每天约翰售出一份零食。当然约翰希望这些零食全部售出后能得到最大的收益,这些零食有以下这些有趣的特性:

  • 零食按照 1 , … , N 1, \ldots, N 1,,N 编号,它们被排成一列放在一个很长的盒子里。盒子的两端都有开口,约翰每天可以从盒子的任一端取出最外面的一个。
  • 与美酒与好吃的奶酪相似,这些零食储存得越久就越好吃。当然,这样约翰就可以把它们卖出更高的价钱。
  • 每份零食的初始价值不一定相同。约翰进货时,第i份零食的初始价值为 V i V_i Vi 1 ≤ V ≤ 1000 1 \leq V \leq 1000 1V1000)。
  • 第i份零食如果在被买进后的第 a a a 天出售,则它的售价是 V i × a V_i \times a Vi×a

V i V_i Vi 的是从盒子顶端往下的第i份零食的初始价值。约翰告诉了你所有零食的初始价值,并希望你能帮他计算一下,在这些零食全被卖出后,他最多能得到多少钱。

输入格式

Line 1: A single integer, N

Lines 2…N+1: Line i+1 contains the value of treat v(i)

输出格式

Line 1: The maximum revenue FJ can achieve by selling the treats

样例 #1

样例输入 #1

5
1
3
1
5
2

样例输出 #1

43

提示

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

思路

  • 盒子的两端都有开口,约翰每天可以从盒子的任一端取出最外面的一个。这句话说明约翰每次都是在区间的外端取出,说明最里面的巧克力最后吃,然后没有被吃的部分就是一个小区间。
  • 对于这种小区间的,我们可以用区间dp来做。
  • 此时我们设f[i][j]表示区间[i,j]的最大钱数
  • 我们先预处理一下就剩一个巧克力的情况,那肯定是 f[i][j]*n,因为最里面的巧克力最后吃。
  • 然后中间过程的状态转移为:f[l][r]=max(f[l+1][r]*(n-(len)+1),f[l][r-1] *(n-len+1)

代码

//这道题是区间dp,因为约翰每天可以从盒子的任一端取出最外面的一个。
//max
//f[i][j]=max(f[i-1][j]+(i+n-j)*v[i],f[i][j+1]+(n+i-j)*v[i])
//预处理的时候肯定是最里面的巧克力最后吃

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int N = 2010;

int w[N];
int n;
int f[N][N];

int main(){
    cin>>n;
    
    for(int i=1;i<=n;i++){
        cin>>w[i];
        f[i][i]=w[i]*n;
    }
    
    for(int len=2;len<=n;len++){
        for(int l=1;l+len-1<=n;l++){
            int r=l+len-1;
            f[l][r]=max(f[l][r-1]+w[r]*(n-len+1),f[l+1][r]+w[l]*(n-len+1));
        }
    }
    
    cout<<f[1][n];
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值