Max Sum of Max-K-sub-sequence(单调队列)

Problem Description

Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input

4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1

Sample Output

7 1 3
7 1 3
7 6 2
-1 1 1

题意  给你一个数列;求该子序列连续区间长度不超过K的最大的和 以及最大和区间的起始和结束位置;

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=3e5+100;
int s[maxn],sum[maxn],f[maxn];
int main(){
	//必须采用数组结构优化算法  否则会超时 
	int t,n,m,k;
	int start,end;
	scanf("%d",&t); 
	while(t--){
		q.clear();
		scanf("%d %d",&n,&k);
		for(int i=1;i<=n;i++){
			scanf("%d",&s[i]);
			s[i+n]=s[i];
			sum[i]=sum[i-1]+s[i];
		}
		for(int i=n+1;i<=n+k-1;i++){
			sum[i]=sum[i-1]+s[i]; 
		}
		int ans=-1000000000;
		int al=maxn/2;
		int ar=maxn/2-1;
		for(int i=1;i<=n+k-1;i++){
			while(ar>=al&&sum[i-1]<sum[f[ar]])ar--; //保证该队列单调递增(头小尾大) 
			while(ar>=al&&i-f[al]>k)al++;  //当不队列的长度大于k要不断弹出头(保证小于K); 
			f[++ar]=i-1;
			if(sum[i]-sum[f[al]]>ans){
				ans=sum[i]-sum[f[al]];
				start=f[al]+1;
				end=i;
			}
		}
		if(end>n)end-=n;
		printf("%d %d %d\n",ans,start,end);
	}
	return 0;
} 

超时代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+100;
int s[maxn],sum[maxn];
deque<int>q;
int main(){
	int t,n,m,k;
	int start,end;
	scanf("%d",&t); 
	while(t--){
		q.clear();
		scanf("%d %d",&n,&k);
		for(int i=1;i<=n;i++){
			scanf("%d",&s[i]);
			s[i+n]=s[i];
			sum[i]=sum[i-1]+s[i];
		}
		for(int i=n+1;i<=n+k-1;i++){
			sum[i]=sum[i-1]+s[i]; 
		}
		
		int ans=-1000000000;
		
		for(int i=1;i<=n+k-1;i++){
			while(!q.empty()&&sum[i-1]<sum[q.back()])q.pop_back(); //保证该队列单调递增(头小尾大) 
			while(!q.empty()&&i-q.front()>k)q.pop_front();  //当不队列的长度大于k要不断弹出头(保证小于K); 
			q.push_back(i-1);
			if(sum[i]-sum[q.front()]>ans){
				ans=sum[i]-sum[q.front()];
				start=q.front()+1;
				end=i;
			}
		}
		if(end>n)end-=n;
		printf("%d %d %d\n",ans,start,end);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值