7-1 电话聊天狂人
分数 25
全屏浏览题目
切换布局
作者 DS课程组
单位 浙江大学
给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。
输入格式:
输入首先给出正整数N(≤105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。
输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。
输入样例:
4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
输出样例:
13588625832 3
#include <iostream>
using namespace std;
#define N 200005
#define mod 200003
typedef long long ll;
struct hash
{
ll tel; //存电话号码
int cnt; //统计号码出现几次
} num[N];
void insert(ll t)
{
int temp, bj;
if (!num[t % mod].cnt) //没有被占用
{
num[t % mod].cnt++;
num[t % mod].tel = t;
}
else if (num[t % mod].cnt && num[t % mod].tel == t) //被占用
num[t % mod].cnt++;//号码一样
else if (num[t % mod].cnt && num[t % mod].tel != t) //被占用,但是号码不一样
{
bj = 1;//标记号码是否出现
temp = t % mod;
while (num[temp].cnt) //查找是否后面有相同号码
{
if (num[temp].tel == t)
{
bj = 0;
num[temp].cnt++;
break;
}
temp = (temp + 1) % mod;//线性探测
}
if (bj) //找到了空位,号码直接填进去
{
num[temp].cnt++;
num[temp].tel = t;
}
}
}
int main()
{
int n;
cin >> n;
ll a, b, minTel = 1e12;
int numb = 0, maxNum = 0, sum = 0;
while (n--)
{
cin >> a >> b;
insert(a);
insert(b);
}
for (int i = 0; i <= mod; i++)
{
if (num[i].cnt && num[i].cnt > maxNum) //当前号码出现次数比记录的大
{
maxNum = num[i].cnt;
minTel = num[i].tel;
}
else if (num[i].cnt && num[i].cnt == maxNum) //当前号码出现次数等于记录的
{
if (num[i].tel < minTel)
minTel = num[i].tel;
}
}
for (int i = 0; i <= mod; i++)
if (num[i].cnt == maxNum)
sum++;
if (sum > 1)
cout << minTel <<' '<< maxNum <<' '<< sum << endl;
else
cout << minTel <<' '<< maxNum << endl;
}
7-2 QQ帐户的申请与登陆
分数 25
全屏浏览题目
切换布局
作者 DS课程组
单位 浙江大学
实现QQ新帐户申请和老帐户登陆的简化版功能。最大挑战是:据说现在的QQ号码已经有10位数了。
输入格式:
输入首先给出一个正整数N(≤105),随后给出N行指令。每行指令的格式为:“命令符(空格)QQ号码(空格)密码”。其中命令符为“N”(代表New)时表示要新申请一个QQ号,后面是新帐户的号码和密码;命令符为“L”(代表Login)时表示是老帐户登陆,后面是登陆信息。QQ号码为一个不超过10位、但大于1000(据说QQ老总的号码是1001)的整数。密码为不小于6位、不超过16位、且不包含空格的字符串。
输出格式:
针对每条指令,给出相应的信息:
1)若新申请帐户成功,则输出“New: OK”;
2)若新申请的号码已经存在,则输出“ERROR: Exist”;
3)若老帐户登陆成功,则输出“Login: OK”;
4)若老帐户QQ号码不存在,则输出“ERROR: Not Exist”;
5)若老帐户密码错误,则输出“ERROR: Wrong PW”。
输入样例:
5
L 1234567890 myQQ@qq.com
N 1234567890 myQQ@qq.com
N 1234567890 myQQ@qq.com
L 1234567890 myQQ@qq
L 1234567890 myQQ@qq.com
输出样例:
ERROR: Not Exist
New: OK
ERROR: Exist
ERROR: Wrong PW
Login: OK
#include <bits/stdc++.h>
using namespace std;
map<string, string> qq;
int main()
{
int n;
cin >> n;
char op;
string qqNum, qqLock;
for (int i = 0; i < n; i++)
{
cin >> op;
cin >> qqNum >> qqLock;
if (op == 'L')
{
if (qq.find(qqNum) == qq.end()) //没找到
cout << "ERROR: Not Exist" << endl;
else
{
if (qq[qqNum] != qqLock)
cout << "ERROR: Wrong PW" << endl;
else
cout << "Login: OK" << endl;
}
}
else if (op == 'N')
{
if (qq.find(qqNum) == qq.end())
{
qq[qqNum] = qqLock;
cout << "New: OK" << endl;
}
else
cout << "ERROR: Exist" << endl;
}
}
}
7-3 航空公司VIP客户查询
分数 25
全屏浏览题目
切换布局
作者 DS课程组
单位 浙江大学
不少航空公司都会提供优惠的会员服务,当某顾客飞行里程累积达到一定数量后,可以使用里程积分直接兑换奖励机票或奖励升舱等服务。现给定某航空公司全体会员的飞行记录,要求实现根据身份证号码快速查询会员里程积分的功能。
输入格式:
输入首先给出两个正整数N(≤105)和K(≤500)。其中K是最低里程,即为照顾乘坐短程航班的会员,航空公司还会将航程低于K公里的航班也按K公里累积。随后N行,每行给出一条飞行记录。飞行记录的输入格式为:18位身份证号码(空格)飞行里程
。其中身份证号码由17位数字加最后一位校验码组成,校验码的取值范围为0~9和x共11个符号;飞行里程单位为公里,是(0, 15 000]区间内的整数。然后给出一个正整数M(≤105),随后给出M行查询人的身份证号码。
输出格式:
对每个查询人,给出其当前的里程累积值。如果该人不是会员,则输出No Info
。每个查询结果占一行。
输入样例:
4 500
330106199010080419 499
110108198403100012 15000
120104195510156021 800
330106199010080419 1
4
120104195510156021
110108198403100012
330106199010080419
33010619901008041x
输出样例:
800
15000
1000
No Info
#include <bits/stdc++.h>
using namespace std;
map<string, int> vip;
int n, k;
int main()
{
int x;
scanf("%d%d", &n, &k);
char id[17];
for (int i = 0; i < n; i++)
{
int dis;
scanf("%s%d", id,&dis);
//getchar();
if (dis < k)
dis = k;
vip[id] += dis;
}
scanf("%d", &x);
for (int i = 0; i < x; i++)
{
char a[17];
scanf("%s", a);
if (vip.find(a) == vip.end())
//cout << "No Info" << endl;
printf("No Info\n");
else
//cout << vip[a] << endl;
printf("%d\n", vip[a]);
}
}
7-4 新浪微博热门话题
分数 25
全屏浏览题目
切换布局
作者 DS课程组
单位 浙江大学
新浪微博可以在发言中嵌入“话题”,即将发言中的话题文字写在一对“#”之间,就可以生成话题链接,点击链接可以看到有多少人在跟自己讨论相同或者相似的话题。新浪微博还会随时更新热门话题列表,并将最热门的话题放在醒目的位置推荐大家关注。
本题目要求实现一个简化的热门话题推荐功能,从大量英文(因为中文分词处理比较麻烦)微博中解析出话题,找出被最多条微博提到的话题。
输入格式:
输入说明:输入首先给出一个正整数N(≤105),随后N行,每行给出一条英文微博,其长度不超过140个字符。任何包含在一对最近的#
中的内容均被认为是一个话题,输入保证#
成对出现。
输出格式:
第一行输出被最多条微博提到的话题,第二行输出其被提到的微博条数。如果这样的话题不唯一,则输出按字母序最小的话题,并在第三行输出And k more ...
,其中k
是另外几条热门话题的条数。输入保证至少存在一条话题。
注意:两条话题被认为是相同的,如果在去掉所有非英文字母和数字的符号、并忽略大小写区别后,它们是相同的字符串;同时它们有完全相同的分词。输出时除首字母大写外,只保留小写英文字母和数字,并用一个空格分隔原文中的单词。
输入样例:
4
This is a #test of topic#.
Another #Test of topic.#
This is a #Hot# #Hot# topic
Another #hot!# #Hot# topic
输出样例:
Hot
2
And 1 more ...
#include <iostream>
#include <set>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
typedef pair<string, int> tc;
int main()
{
set<string> topics;
map<string, int> topics_cnt;
int n;
cin >> n;
getchar();
string str, topic;
for (int i = 0; i < n; ++i)
{
getline(cin, str);
for (int j = 0; j < str.size(); ++j)
if (str[j] == '#')
{
j += 1;
while (str[j] != '#')
{
if (isalnum(str[j]))
topic += str[j];
else //测试点2:非英文字母和数字符号也具有分词作用
{
while (!isalnum(str[++j]) && str[j] != '#');
if (str[j] != '#' && !topic.empty())
topic += ' ';
j -= 1;
}
++j;
}
transform(topic.begin(), topic.end(), topic.begin(), ::tolower);
topics.insert(topic);
topic = "";
}
for (auto &t: topics)
topics_cnt[t] += 1;
topics.clear();
}
vector<tc> cup(topics_cnt.begin(), topics_cnt.end());
sort(cup.begin(), cup.end(), [](tc &a, tc &b) { return a.second > b.second; });
int index = 0;
string hottest_topic = cup[0].first;
while (++index < cup.size() && cup[index].second == cup[0].second)
if (cup[index].first < hottest_topic)
hottest_topic = cup[index].first;
hottest_topic[0] = toupper(hottest_topic[0]);
cout << hottest_topic << endl << cup[0].second << endl;
if (index > 1) //测试点3
cout << "And " << index - 1 << " more ...";
}