6-1 Shortest Path [3]

Shortest Path [3] (10分)
Write a program to not only find the weighted shortest distances, but also count the number of different minimum paths from any vertex to a given source vertex in a digraph. It is guaranteed that all the weights are positive.

Format of functions:
void ShortestDist( MGraph Graph, int dist[], int count[], Vertex S );where MGraphis defined as the following:

typedef struct GNode *PtrToGNode;
struct GNode{
    int Nv;
    int Ne;
    WeightType G[MaxVertexNum][MaxVertexNum];
};
typedef PtrToGNode MGraph;

The shortest distance from V to the source S is supposed to be stored in dist[V]. If V cannot be reached from S, store -1 instead. The number of different minimum paths from V to the source S is supposed to be stored in count[V] and count[S]=1.
Sample program of judge:

#include <stdio.h>
#include <stdlib.h>

typedef enum {false, true} bool;
#define INFINITY 1000000
#define MaxVertexNum 10  /* maximum number of vertices */
typedef int Vertex;      /* vertices are numbered from 0 to MaxVertexNum-1 */
typedef int WeightType;

typedef struct GNode *PtrToGNode;
struct GNode{
    int Nv;
    int Ne;
    WeightType G[MaxVertexNum][MaxVertexNum];
};
typedef PtrToGNode MGraph;

MGraph ReadG(); /* details omitted */

void ShortestDist( MGraph Graph, int dist[], int count[], Vertex S );

int main()
{
    int dist[MaxVertexNum], count[MaxVertexNum];
    Vertex S, V;
    MGraph G = ReadG();

    scanf("%d", &S);
    ShortestDist( G, dist, count, S );

    for ( V=0; V<G->Nv; V++ )
        printf("%d ", dist[V]);
    printf("\n");
    for ( V=0; V<G->Nv; V++ )
        printf("%d ", count[V]);
    printf("\n");

    return 0;
}

/* Your function will be put here */

Sample Input (for the graph shown in the figure):
在这里插入图片描述

8 11
0 4 5
0 7 10
1 7 30
3 0 40
3 1 20
3 2 100
3 7 70
4 7 5
6 2 1
7 5 3
7 2 50
3

Sample Output:

40 20 100 0 45 53 -1 50 
1 1 4 1 1 3 0 3 

这道题目嘛,很典型的dikstra算法,只不过多了一个count数组而已,基本思想还是很简单,每次在“贪”新的一个结点的时候,还要考虑临接点中已经被访问过了的节点,看新的“贪”的这个点会不会让它的count++.需要注意的是邻接矩阵里的元素都是被初始化为INFINITY的。

接下来附上测试程序自带的 ReadG()函数:

MGraph ReadG(void)
{
	MGraph G=(MGraph)malloc(sizeof(struct GNode));
	scanf("%d%d",&G->Nv,&G->Ne);
	int i,j;
	for(i=0;i<G->Nv;i++)
	{
		for(j=0;j<G->Nv;j++)
		{
			G->G[i][j]=INFINITY;//注意测试程序也是把邻接矩阵默认设置为INFINITY的
		}
	}
	for(i=0;i<G->Ne;i++)
	{
		int a,b,x;
		scanf("%d%d%d",&a,&b,&x);
		G->G[a][b]=x;
	}
	
	return G;
}

下面附上函数代码

int asked[MaxVertexNum];
void ShortestDist( MGraph Graph, int dist[], int count[], Vertex S )
{
    int i;
    for(i=0;i<Graph->Nv;i++)
    {
        dist[i]=Graph->G[S][i];
        asked[i]=0;
        count[i]=0;
    }
    dist[S]=0;
    //asked[S]=1;注意asked[0]一开始不能初始化为1,否则邻接点的count也需要事先初始化
    count[S]=1;
    while(1)
    {
        //在所有未被纳入的点中找一个dist最小点
        int min=INFINITY;
        int minindex=-1;
        for(i=0;i<Graph->Nv;i++)
        {
            if(!asked[i]&&dist[i]<min)
            {
                min=dist[i];
                minindex=i;
            }
        }
        if(minindex==-1)break;
        asked[minindex]=1;
        for(i=0;i<Graph->Nv;i++)
        {
            if(Graph->G[minindex][i]!=INFINITY&&i!=minindex)
            {
                if(dist[minindex]+Graph->G[minindex][i]<dist[i])
                {
                    dist[i]=dist[minindex]+Graph->G[minindex][i];
                    count[i]=count[minindex];
                }
                else if(dist[minindex]+Graph->G[minindex][i]==dist[i])
                {
                    count[i]+=count[minindex];
                }
            }
        }
    }
    for(i=0;i<Graph->Nv;i++)
    {
        if(dist[i]==INFINITY)
        {
            dist[i]=-1;
            count[i]=0;
        }
    }
}
  • 8
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值