PTA 数据结构起步能力自测题4~5

4.

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

 

#include<stdio.h>
#include<string.h>
int main()
{
    char a[22],b[22];
    int c[10]={0},d=0,e=0,i,j,n;
    gets(a);
    n=strlen(a);
    for( i=0;i<n;i++)
    {
        d=a[i]-48;  //字符0的ASCII码值为48
        c[d]++;//存储不同数出现的次数 
    }
    for( j=0;j<n+1;j++,i--)//翻倍后的数可能会比原数多一位所以“j<n+1”
    {
    	if(j==n)//最后一位数记录是否进位
    	{
    		if(e==1)
    			b[j]='1';//需要进位记为1
    		else
    			b[j]='0';//不需要进位则记为0
		}
    	else 
		{
			if(a[i-1]+a[i-1]-48+e<=57)//不需要进位
    		{
    			b[j]=a[i-1]+a[i-1]-48+e;//直接赋给b
				e=0;//无需进位e为0
			}
    		else
    		{
    			b[j]=a[i-1]+a[i-1]-48-10+e;//需要进位需要多减去10
    			e=1;//需要进位e为1
			}
			d=b[j]-48;//b[]中出现的数字
			c[d]--;//c[]中对应的值需减1
		}
    }
    b[j]='\0';//字符串结束的标志 
    for(i=0;i<10;i++){
    	if(c[i]!=0||b[j-1]=='1')//c[]中有非0值或者原数翻倍后位数增加了
    	{
    		printf("No\n");	
    		break;
		}
	}
    	
	if(i==10){
		printf("Yes\n");
	}
		
    int m=strlen(b);
    if(b[j-1]=='0')
    	m=m-1;//不输出最后一位的'0'
    for(m=m-1;m>=0;m--)//逆序b[]
    	printf("%c",b[m]);
    	return 0;
}

5.

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 

#include <stdio.h>
#include <string.h>
typedef struct{
	char a[54][10];
}Card; 
int main()
{
	int n=54,b[54],m=0,i=0,j=0,c[54];
	Card card={{"S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
	"H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
	"C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
	"D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13","J1","J2"	}}; 
	scanf("%d",&m);//读入洗的次数 
	for(i=0;i<n;i++)
	{
		scanf("%d",&b[i]);//读入洗的顺序
	}	 		 
	for(i=0;i<n;i++)
	{
		c[i]=i;
	}	
	for(j=0;j<m;j++)//洗牌循环 
	{	
		int d[54]={0};//中间数组 
		for(i=0;i<n;i++)
		{
			d[b[i]-1]=c[i]; 
		}
		for(i=0;i<n;i++)
		{
		  c[i]=d[i];//改变输出顺序
		} 		
	}
	for(i=0;i<n-1;i++)
	{
		printf(card.a[c[i]]);
		printf(" ");
	}		
		printf(card.a[c[i]]);
 } 	

 第四道题我写了很久,还参考了别人的写法,第五道题就比较简单,和以前做过的题几乎一样,没有太大难度。第四题的难点是输入的数太大,超过了long long int,用字符串或者字符数组读进来后还面临乘二进一的问题。

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值