【id:123】【10分】E. OOP一元多项式类运算(类+对象)
时间限制
1s
内存限制
128MB
题目描述
一元多项式按照升幂表示为:
Pn(x) = p0+ p1x + p2x2+ … +pnxn。(n>=0)
构建一元多项式类,数据成员用于保存多项式中每项的系数和指数,数据操作实现两个一元多项式的加、减、乘。
输入
测试数据数
对于每组测试数据
第一行,第一个多项式:多项式项数n 系数1 指数1 系数2 指数2 ...... 系数n 指数n
第二行,第二个多项式:多项式项数n 系数1 指数1 系数2 指数2 ......系数n 指数n
数据保证输入数据中多项式均为升幂且所有数据都为整数
输出
每组测试数据输出三行,分别是两个多项式的加、减、乘。
具体输出格式见样例(即人们习惯的多项式表示,需要额外注意系数或指数为1,-1的情况。)
样例查看模式
正常显示
查看格式
输入样例1 <-复制
2
3 -9 0 4 1 -3 5
1 -7 0
2 1 0 -1 3
3 1 0 1 1 -1 2
输出样例1
-16+4x-3x^5
-2+4x-3x^5
63-28x+21x^5
2+x-x^2-x^3
-x+x^2-x^3
1+x-x^2-x^3-x^4+x^5
注意的点:
-
使用一个数组来表示多项式,下标表示指数,数值表示系数
-
之前使用map的时候部分正确,不知道原因
-
注意输出的格式
-
分为下标0,下标1,下标其他进行输出
#include<iostream>
#include<iomanip>
using namespace std;
class Node {
public:
int *xi;
explicit Node(int *xi);
Node();
int *ADD(int *temp);
int *SUB(int *temp);
int *MULTI(int *temp);
void print(int *temp);
};
Node::Node() {}
Node::Node(int *xi) {
this->xi = new int[50];
for (int i = 0; i < 50; ++i) {
this->xi[i] = xi[i];
}
}
void Node::print(int *temp) {
bool first = true;
int count = 0;
for (int i = 0; i < 50; ++i) {
if (temp[i] == 0) {
count++;
}
}
if (count == 50) {
cout << 0 << endl;
return;
}
if (temp[0] != 0) {
first = false;
if (temp[0] == 1) {
cout << 1;
} else if (temp[0] == -1) {
cout << -1;
} else {
cout << temp[0];
}
}
if (temp[1] != 0) {
if (first) {
first = false;
if (temp[1] == 1) {
cout << 'x';
} else if (temp[1] == -1) {
cout << "-x";
} else {
cout << temp[1] << "x";
}
} else {
if (temp[1] == 1) {
cout << "+x";
} else if (temp[1] == -1) {
cout << "-x";
} else if (temp[1] > 0) {
cout << "+" << temp[1] << "x";
} else {
cout << temp[1] << "x";
}
}
}
for (int i = 2; i < 50; ++i) {
if (first) {
if (temp[i] == 0) {
continue;
}
first = false;
if (temp[i] == 1) {
cout << "x^" << i;
} else if (temp[i] == -1) {
cout << "-x^" << i;
} else {
cout << temp[i] << "x^" << i;
}
} else {
if (temp[i] == 0) {
continue;
}
if (temp[i] == 1) {
cout << "+x^" << i;
} else if (temp[i] == -1) {
cout << "-x^" << i;
} else if (temp[i] < 0) {
cout << temp[i] << "x^" << i;
} else {
cout << "+" << temp[i] << "x^" << i;
}
}
}
cout << endl;
}
int *Node::ADD(int *temp) {
int *res = new int[50];
for (int i = 0; i < 50; ++i) {
res[i] = xi[i] + temp[i];
}
print(res);
return res;
}
int *Node::SUB(int *temp) {
int *res = new int[50];
for (int i = 0; i < 50; ++i) {
res[i] = xi[i] - temp[i];
}
print(res);
return res;
}
int *Node::MULTI(int *temp) {
int *res = new int[50];
for (int i = 0; i < 50; ++i) {
res[i] = 0;
}
for (int i = 0; i < 50; ++i) {
if (xi[i] == 0) {
continue;
}
// //-----
// int *multiTemp = new int[50];
// for (int j = 0; j < 50; ++j) {
// multiTemp[i] = 0;
// }
// //-----
// multiTemp[i] = xi[i];
//xi*temp
for (int j = 0; j < 50; ++j) {
if (temp[j] == 0) {
continue;
}
res[i + j] += xi[i] * temp[j];
}
}
print(res);
return res;
}
int main() {
int tiems;
cin >> tiems;
while (tiems--) {
int *xi = new int[50];
for (int i = 0; i < 50; ++i) {
xi[i] = 0;
}
int n;
cin >> n;
for (int i = 0; i < n; ++i) {
int a, b;
cin >> a >> b;
xi[b] = a;
}
Node one(xi);
//第二个
for (int i = 0; i < 50; ++i) {
xi[i] = 0;
}
cin >> n;
for (int i = 0; i < n; ++i) {
int a, b;
cin >> a >> b;
xi[b] = a;
}
Node two(xi);
one.ADD(two.xi);
one.SUB(two.xi);
one.MULTI(two.xi);
}
}