Acwing873. 欧拉函数

给定 n 个正整数 ai,请你求出每个数的欧拉函数。

在这里插入图片描述
输入格式
第一行包含整数 n。

接下来 n 行,每行包含一个正整数 ai。

输出格式
输出共 n 行,每行输出一个正整数 ai 的欧拉函数。

数据范围
1≤n≤100,
1≤ai≤2×109
输入样例:
3
3
6
8
输出样例:
2
2
4

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cmath>
#include <queue>
using namespace std;

typedef unsigned long long ull;
const int N = 1e6+10,P=1e9+7 ;
int n, m,len=1,z=0;
int a[110],dist[N];
bool st[N];
int dx[]= {1,-1,2};

int main()
{
    int x,y,i,j,t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int sum=0,cnt=n;
        for(i=2; i<=n/i; i++)//找质因子
        {
            if(n%i==0)
            {
                cnt=cnt/i*(i-1);//防止小数所以先除i
                while(n%i==0)//把质因子倍数除尽
                    n=n/i;
            }
        }
        if(n>1)
            cnt=cnt/n*(n-1);
            cout<<cnt<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值