zcmu-5117: Simple Parenthesis Matching(思维)

题目描述

Given a string P only consist of characters with (), [] and {}. Now BaoBao wants to know whether P can form a valid bracket string.

As we can know, in a valid bracket string, for each "(", we can find a ")" behind it. In the same way, "[" and "{" also can find their "]" and "}".

For example, "()","[]","{}","(()())","({})" are the valid bracket string.

输入

The first line contains a integer T(1 <= T <= 100), which indicates the number of test cases.

The next T lines, each line only contains a bracket string Pi(|Pi| <= 2*105).

It guaranteed that the sum of |Pi| <= 2*105.

输出

For each test cases, you just output "YES" if the string is valid or "NO" for not valid.

样例输入

4

({})

{{}}

({[}])

}{

样例输出

YES

YES

YES

NO

注释:写道简单思维题放松一下

代码:

#include<bits/stdc++.h>
using namespace std;
int s1[6];
int t;
string s;
int main(){
	while(~scanf("%d",&t)){
		memset(s1,0,sizeof(s1));
		cin>>s;
		int n=s.size();
		int q=1;
		for(int i=0;i<n;i++){
			if(s[i]=='(')s1[0]++;
			if(s[i]==')')s1[1]++;
			if(s[i]=='[')s1[2]++;
			if(s[i]==']')s1[3]++;
			if(s[i]=='{')s1[4]++;
			if(s[i]=='}')s1[5]++;
			if(s1[0]<s1[1]||s1[2]<s1[3]||s1[4]<s1[5]){
				q=0;break;
			}
		}
		if(s1[0]!=s1[1]||s1[2]!=s1[3]||s1[4]!=s1[5])q=0;
		if(q)printf("YES\n");
		else printf("NO\n");
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

emo的鱼香roise

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值