zcmu-1231: Antimonotonicity(思维)

Description
I have a sequence Fred of length n comprised of integers between 1 and n inclusive. The elements of Fred are pairwise distinct. I want to find a subsequence Mary of Fred that is as long as possible and has the property that:

   Mary[0] > Mary[1] < Mary[2] > Mary[3] < ...
Input
The first line of input will contain a single integer T expressed in decimal with no leading zeroes. T will be at most 50. T test cases will follow.

Each test case is contained on a single line. A line describing a test case is formatted as follows:

   n Fred[0] Fred[1] Fred[2] ... Fred[n-1].
where n and each element of Fred is an integer expressed in decimal with no leading zeroes. No line will have leading or trailing whitespace, and two adjacent integers on the same line will be separated by a single space. n will be at most 30000.

 
Output
For each test case, output a single integer followed by a newline --- the length of the longest subsequence Mary of Fred with the desired properties.

 
Sample Input
4
5 1 2 3 4 5
5 5 4 3 2 1
5 5 1 4 2 3
5 2 4 1 3 5
Sample Output
1
2
5
3

注释:假设a,b,c,d四个数,a>b>c<d并且b>d;那么最长为acd,如果符合条件自然是要x变成y,如果不符合条件如上式c<b;那么使得d可以取的范围更大,所以x也要变成y;因此每一次判断x都要变成y。其实跟最长递增子序列的思想差不多。

代码:

#include<bits/stdc++.h>
using namespace std;
int t,n;
int main(){
	while(~scanf("%d",&t)){
		while(t--){
			scanf("%d",&n);
			int x,y,z=0,sum=1;
			scanf("%d",&x);
			for(int i=2;i<=n;i++){
				scanf("%d",&y);
					if(z==0){
						if(y<x){
							sum++;
							z=1;
						}
					}
					else{
						if(y>x){
							sum++;
							z=0;
						}
					}
					x=y;
				}
			printf("%d\n",sum);
	}
}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

emo的鱼香roise

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值