zcmu-1375: Zero of factorial(二分)

17 篇文章 0 订阅
2 篇文章 0 订阅

Description

Define f (n) as the number of zeros at the end of n!, for example, f (4) = 0, f (5) = 1. Your task is to find the minimum n satisfying f (n) = x for a given value x.

Input

Multiple groups of test data, each group of test data contains a positive integer x (1 < = x < = 10 ^ 8).

Output

For each group of test data, output the corresponding n. if n is not exist, output "No solution"(without quotation).

Sample Input

2

5

Sample Output

10

No solution

HINT

water problem!

代码:

#include<bits/stdc++.h>
using namespace std;
const int inf=0x3f3f3f3f;
int x;
int erfen(int mid){
	int sum=0;
	while(mid){
		sum+=mid/5;
		mid/=5;
	}
	return sum;
}
int main(){
	while(~scanf("%d",&x)){
		int l=0,r=inf;
		int mid,flag=0;
		while(l<r){
			mid=(l+r)/2;
			int w=erfen(mid);
			if(w==x){
				while(mid%5){
					mid--;
				}
				flag=1;
				break;
			}
			else if(w<x){
				l=mid+1;
			}
			else r=mid-1;
		}
		if(flag)cout<<mid<<endl;
		else cout<<"No solution\n";
	}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

emo的鱼香roise

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值