Real Small Water Problem

问题描述
The senior wanted you to create a water problem.This made you a headache.So you asked BingYu for help.Immediately after he listened,he came up with a problem:
Give you a positive integer n.
Function F_x satisfies:
   F_(0) = sin{n}
   F_(x) = sin{F_(x-1)} (x>0)
Calculate F_(n).

输入格式

The input contains no more than 20 test cases.
For each test case, the only line consists of one integer n.
0<=n<=100.

输出格式

For each given n, print the answer in a single line.The result should be rounded to six decimal places.

输入样例

0
1
2

输出样例

0.000000
0.745624
0.709700
 

#include <iostream>

#include <cstdio>

#include<cmath>

using namespace std;

int functin(double result,int t,int n){

  result=sin(result);

  if(t==n) printf("%.6lf\n",result);

  else functin(result,t+1,n);

}

int main(){

  int n;

  double result;

  while(cin>>n){

    int t=0;

    result=n;

    functin(result,t,n);

  }

  return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值