【蓝桥杯每日一练:Real Small Water Problem】

问题描述

The senior wanted you to create a water problem.This made you a headache.So you asked BingYu for help.Immediately after he listened,he came up with a problem:
Give you a positive integer n.
Function F_x satisfies:
   F_(0) = sin{n}
   F_(x) = sin{F_(x-1)} (x>0)
Calculate F_(n).

输入格式

The input contains no more than 20 test cases.
For each test case, the only line consists of one integer n.
0<=n<=100.

输出格式

For each given n, print the answer in a single line.The result should be rounded to six decimal places.

输入样例

0
1
2

输出样例

0.000000
0.745624
0.709700

代码

import math
from decimal import Decimal
def f(x,n):
    if x==0:
        return math.sin(n)
    elif n>0:
        return math.sin(f(x-1,n))
while True:
    n=float(input())
    m=n
    print("%.6f"%f(n,m))

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zjf时空方程

感谢各位的支持,我一定会努力!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值