1041 Be Unique (20 分)-PAT甲级

Being unique is so important to people on Mars that even(甚至) their lottery(彩票) is designed in a unique way. The rule of winning is simple(简单的): one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

思路:1.统计输入数字出现总次数,并将输入的数字按照输入顺序存放到一个数组,之后按输入顺序遍历数组,找到第一个出现次数为1(即unique数字)的数字并输出,如果没有找到,就输出None

           2.统计输入数字出现总次数的目的是为了后面查询数字出现次数,可以通过普通数组,map或者unordered_map来实现,效率比较(按时间花费升序排列):普通数组>map>unordered_map

AC代码

#include <iostream>
#include <vector>
#include <unordered_map> 
using namespace std;
int main()
{
	vector<int >a;
	unordered_map<int,int>b; 
	int n,temp;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>temp;
		a.push_back(temp);
		b[temp]++;
	}
	bool flag=false;
	for(int i=0;i<a.size();i++)
	{
		if(b[a[i]]==1)
		{
			cout<<a[i];
			flag=true;
			break;
		}
	}
	if(!flag)
		cout<<"None"; 
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值