1007 Maximum Subsequence Sum (25 分)-PAT甲级

Given a sequence(序列,数列) of K integers { N1​, N2​, ..., NK​ }. A continuous(连续的) subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum(最大的) subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique(唯一的), output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 题目大意:给定一个数组,找出给定数组的子数组元素和最大的子数组(子数组包括本身),如果这样的数组不唯一,就输出下标最小的情况,如果K个元素都是负数,子数组最大和就是0,子数组就是数组本身。

 思路:本题解法有多种,可以暴力枚举,也可以使用比较巧妙的方法,如使用数组前缀和。

数组前缀和分为一维数组前缀和和二维数组前缀和,本题用到的是一维数组前缀和,但二维数组前缀和更为有用,感兴趣的可以去搜索一下。

定义一个前缀和数组sum[10001],sum[i]保存的是前i项的元素和,当要求下标区间[i,j]的子数组的元素和时,可以利用sum[j]-sum[i-1]来求出,这样就避免了普通枚举因重复计算而带来的时间消耗问题,大大提高时间效率(每一个子数组和只需要调用公式sum[j]-sum[i-1]一次)。

 AC代码

#include <iostream>
using namespace std;
int sum[10001]={0},num[10001];//sum数组存前缀和,num数组存输入的元素 
struct ans
{
	int num;
	int i;
	int j;
}maxn;
int main()
{
	int n;
	bool flag=false;//flag用来判断是否出现非负数 
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		cin>>num[i];
		if(num[i]>=0)
			flag=true;
		sum[i]=sum[i-1]+num[i];//构造数组前缀和 
	}
	if(!flag)//输入全部为负数 
		cout<<0<<" "<<num[1]<<" "<<num[n];
	else
	{
		maxn={sum[1],1,1};
		for(int i=1;i<=n;i++)
			for(int j=i;j<=n;j++)
			{
				if(maxn.num<sum[j]-sum[i-1])//筛选,动态更新answer 
					maxn={sum[j]-sum[i-1],i,j};			
			}
		cout<<maxn.num<<" "<<num[maxn.i]<<" "<<num[maxn.j];
	}
	return 0;
}

更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值