1051 Pop Sequence (25 分)-PAT甲级

Given a stack which can keep M numbers at most(至多). Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

 题目大意:判断一串序列是否可能是一个栈中元素按出来顺序所组成的序列。

 思路:可以模拟栈的执行过程,如果执行过程栈顶元素和目标序列中对应位置的元素不相符,即说明该序列不是栈pop出的序列。

因为要把元素push入栈才能pop,所以失败原因主要有两点:1.要pop出的元素不是栈顶元素

2.要pop出的元素pop时,栈早已达到栈的最大空间

AC代码 

#include <iostream>
#include <stack>
#include <vector>
using namespace std;
int main() {
	int M, N, K;
	cin >> M >> N >> K;
	while (K--) {
		stack<int> s; 
		vector<int> a(N + 1);
		for (int i = 1; i <= N; i++) cin >> a[i]; // 将目标序列存入数组 
		int current = 0, i;
		for (i = 1; i <= N; i++) {
			/* 按照栈pop的流程,要pop出指定元素,需要将指定元素压入栈
				并且作为栈顶 */ 
			while (current < a[i] && current < N && s.size() < M) {
				current++;
				s.push(current);
			}
			/* 这个条件说明栈顶元素是目标序列中对应的元素  */ 
			if(!s.empty() && a[i] == s.top()) s.pop();  
			else break;
		}
		/* i == N + 1说明成功模拟出目标序列  */ 
		if (i == N + 1) cout << "YES" <<endl; 
		else cout << "NO" <<endl;
	}	
	return 0;
}

 更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值