1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.


Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题目大意

求俩个非递减数列的合并后的中位数


思路

 读入第一个数组后,开始一边读入第二个数组,一边动态判断数的大小,当该数的大小排在(N+M+1)/2的时候,即为中位数


C/C++ 

#include <iostream>
using namespace std;
int nums[200005];
int main(){
    int N, M,key,op=1,num;
    cin >> N;
    for(int z=1;z<=N;z++) cin >> nums[z];
    cin >> M;
    key = (N+M+1)/2;
    for(int z=1;z<=M;z++) {
        cin >> num;
        while (op<=N && nums[op]<num) {
            if(--key==0) cout << nums[op];
            op++;
        }
        if (--key == 0) cout << num;
    }
    while(op<=N){
        if (--key==0) cout << nums[op];
        op++;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三块不一样的石头

十分满意,一分打赏~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值