PAT A1029:Median之sort排序

题目描述

PAT A1029
1029 Median (25分)
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10^5 ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:
For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

求解思路

一开始使用的是multiset,只能使用迭代器访问,所以使用了一个变量控制,到达了中位即输出。但由于数据量可能过大,导致了运行超时,所以使用sort排序后直接用下标访问。

实现代码(AC)

#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	int n,m;
	scanf("%d",&n);
	int a[n];
	//multiset<int>s;
	vector<int>s;
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		s.push_back(a[i]);
	}	
	scanf("%d",&m);
	int b[m];
	for(int i=0;i<m;i++)
	{
		scanf("%d",&b[i]);
		s.push_back(b[i]);
	}
	sort(s.begin(),s.end()); 
	printf("%d\n",s[(n+m-1)/2]);
	return 0;
}

代码(最后一组数据运行超时)

#include<cstdio>
#include<iostream>
#include<set>
using namespace std;
int main()
{
	int n,m;
	scanf("%d",&n);
	int a[n];
	multiset<int>s;
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		s.insert(a[i]);
	}	
	scanf("%d",&m);
	int b[m];
	for(int i=0;i<m;i++)
	{
		scanf("%d",&b[i]);
		s.insert(b[i]);
	}
	int count=0;
	for(multiset<int>::iterator it=s.begin();it!=s.end();it++,count++)
	{
		if(count==(n+m-1)/2)	printf("%d\n",*it);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值