L2-006 树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2
#include<iostream>
#include<queue>
#include<vector>

using namespace std;

struct ty
{
    int l=0,r=0;	
};

ty tree[44];
int n;
int a[44];
int b[44];
vector<int>ans;

int build(int l1,int r1,int l2,int r2)
{
	if(l1>r1)return 0;
	int tr=a[r1];
	int p1=l2;
	while(b[p1]!=tr)++p1;
	int p2=p1-l2;
	tree[tr].l=build(l1,l1+p2-1,l2,p1-1);
	tree[tr].r=build(l1+p2,r1-1,p1+1,r2);
	return tr;
}


void bfs(int x)
{
	queue<int>q;
	q.push(x);
	while(!q.empty())
	{
		int xx=q.front();
		q.pop();
		ans.push_back(xx);
		if(tree[xx].l!=0)q.push(tree[xx].l);
		if(tree[xx].r!=0)q.push(tree[xx].r); 	
	}
	
	for(int i=0;i<ans.size()-1;++i)
	{
		cout<<ans[i]<<" ";
	}
	cout<<ans[ans.size()-1];
}

int main()
{
	cin>>n;
	for(int i=1;i<=n;++i)cin>>a[i];
	for(int i=1;i<=n;++i)cin>>b[i];
	
	int tr=build(1,n,1,n);
	
	bfs(a[n]);
	
	return 0;
}









 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值