1062 Talent and Virtue(55行代码+超详细注释,看了必会)

该文描述了一个基于900年前中国哲学家SimaGuang的人才理论的问题,需要对一组人的才智和美德分数进行排名。按照他的理论,人才被分为‘圣人’、‘君子’、‘愚人’和‘小人’四类,并给出了具体的分数标准。程序需处理输入数据,按规则对人才进行分类和排序,输出实际排名结果。
摘要由CSDN通过智能技术生成

分数 25

全屏浏览题目

切换布局

作者 CHEN, Li

单位 浙江大学

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are considered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=100005;
struct peo{//结构体,分别存每个人的编号,德分,才分 
    string id;
    int vs,ts;
}res1[N],res2[N],res3[N],res4[N];
int c1,c2,c3,c4;
bool cmp(peo a,peo b){//排序,若总分数不等按分数非递增排序,否则若德分不等按德分非递增排序,否则按编号递增排序 
    return a.ts+a.vs!=b.ts+b.vs?a.ts+a.vs>b.ts+b.vs:(a.vs!=b.vs?a.vs>b.vs:a.id<b.id);
}
int main(){
    int n,l,h;
    cin>>n>>l>>h;
    for(int i=0;i<n;i++){
        string id;
        int v,t;
        cin>>id>>v>>t;//输入 
        if(v<l||t<l)continue;//只要德分或才分小于最低分则不参与排序 
        if(v>=h&&t>=h){//圣人档 
            res1[c1].id=id;
            res1[c1].vs=v;
            res1[c1].ts=t;
            c1++;
        }
        else if(t<h&&v>=h){//君子档 
            res2[c2].id=id;
            res2[c2].vs=v;
            res2[c2].ts=t;
            c2++;
        }
        else if(t<h&&v<h&&t<=v){//愚人档 
            res3[c3].id=id;
            res3[c3].ts=t;
            res3[c3].vs=v;
            c3++;
        }
        else{//小人档 
            res4[c4].id=id;
            res4[c4].ts=t;
            res4[c4].vs=v;
            c4++;
        }
    }
    sort(res1,res1+c1,cmp);//分别排序 
    sort(res2,res2+c2,cmp);
    sort(res3,res3+c3,cmp);
    sort(res4,res4+c4,cmp);
    cout<<c1+c2+c3+c4<<endl;
    for(int i=0;i<c1;i++)printf("%s %d %d\n",res1[i].id.c_str(),res1[i].vs,res1[i].ts);//按序输出 
    for(int i=0;i<c2;i++)printf("%s %d %d\n",res2[i].id.c_str(),res2[i].vs,res2[i].ts);
    for(int i=0;i<c3;i++)printf("%s %d %d\n",res3[i].id.c_str(),res3[i].vs,res3[i].ts);
    for(int i=0;i<c4;i++)printf("%s %d %d\n",res4[i].id.c_str(),res4[i].vs,res4[i].ts);
    return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值