1081 Rational Sum(24行代码+超详细注释)

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

防溢出:多约分就完事了!!!

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b){//求公因数,常用模板 
    return b==0?a:gcd(b,a%b);
}
int main(){
    #ifdef ONLINE_JUDGE
    #else
         freopen("1.txt","r",stdin);
    #endif
    int n;
    cin>>n;
    ll a=0,b=1;
    for(int i=0;i<n;i++){
        ll c,d;
        scanf("%lld/%lld",&c,&d);
        int t=gcd(b,d);//求分母的公因数 
        a=(a*d+b*c)/t,b=b*d/t;//约分 
        t=gcd(a,b);//求分子和分母的公因数 
        a/=t,b/=t;//约分 
    }
    if(b==1)cout<<a<<endl;//若是整数 
    else{//若不是整数 
        if(a>b)printf("%d",a/b);//若是假分式 
        printf("%lld/%lld\n",a,b);//输出剩下真分式 
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值