1156 Sexy Primes(29行代码+详细注释)

分数 20

全屏浏览题目

切换布局

作者 陈越

单位 浙江大学

Sexy primes are pairs of primes of the form (p, p+6), so-named since "sex" is the Latin word for "six". (Quoted from http://mathworld.wolfram.com/SexyPrimes.html)

Now given an integer, you are supposed to tell if it is a sexy prime.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤108).

Output Specification:

For each case, print in a line Yes if N is a sexy prime, then print in the next line the other sexy prime paired with N (if the answer is not unique, output the smaller number). Or if N is not a sexy prime, print No instead, then print in the next line the smallest sexy prime which is larger than N.

Sample Input 1:

47

Sample Output 1:

Yes
41

Sample Input 2:

21

Sample Output 2:

No
23

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
int n;
bool isprime(int a){//判断是否为素数 
    if(a<=1)return false;
    for(int i=2;i*i<=a;i++)
        if(a%i==0)return false;
    return true;
}
int main(){
    cin>>n;
    if(isprime(n-6)&&isprime(n)){//若n是性感素数对里大的那个素数,输出n-6 
        puts("Yes");
        cout<<n-6<<endl;
    }
    else if(isprime(n)&&isprime(n+6)){//若n是性感素数对里小的那个,输出n 
        puts("Yes");
        cout<<n<<endl;
    }
    else{//若n不是性感素数对里的任何一个 
        puts("No");
        int i=n+1;
        while(!isprime(i-6)||!isprime(i))i++;//当i是性感素数对里大的那个素数时 
        int j=n+1;
        while(!isprime(j)||!isprime(j+6))j++;//当j是性感素数对里小的那个素数时 
        printf("%d\n",i<j?i:j); //输出更小的那个 
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值