1054 The Dominant Color【超简单思路】

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

题目大意:给一个n*m大小的图片,给出这个图片的每一个颜色,找出这张图片的主色,主色占总数的一半以上。最后输出这个颜色

解题思路:用map,key存颜色,value表示次数,key每出现一次就加一。最后遍历找到主色 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
map<ll,ll>mp;
int main(){
    ios::sync_with_stdio(0);
    cin.tie(0);
    ll n,m,x;
    cin>>n>>m;
    for(int i=0;i<m;i++){
         for(int j=0;j<n;j++){
              cin>>x;
              mp[x]++;
         }
    }
    for(auto &it:mp){
        if(it.second>n*m/2){
           cout<<it.first;
            break;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值