1053 Entropy 哈弗曼编码 贪心算法


Entropy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71 Accepted Submission(s): 41
Problem DescriptionAn entropy encoder is a data encoding method that achieves lossless data compression by encoding a message with “wasted” or “extra” information removed. In other words, entropy encoding removes information that was not necessary in the first place to accurately encode the message. A high degree of entropy implies a message with a great deal of wasted information; english text encoded in ASCII is an example of a message type that has very high entropy. Already compressed messages, such as JPEG graphics or ZIP archives, have very little entropy and do not benefit from further attempts at entropy encoding.

English text encoded in ASCII has a high degree of entropy because all characters are encoded using the same number of bits, eight. It is a known fact that the letters E, L, N, R, S and T occur at a considerably higher frequency than do most other letters in english text. If a way could be found to encode just these letters with four bits, then the new encoding would be smaller, would contain all the original information, and would have less entropy. ASCII uses a fixed number of bits for a reason, however: it’s easy, since one is always dealing with a fixed number of bits to represent each possible glyph or character. How would an encoding scheme that used four bits for the above letters be able to distinguish between the four-bit codes and eight-bit codes? This seemingly difficult problem is solved using what is known as a “prefix-free variable-length” encoding.

In such an encoding, any number of bits can be used to represent any glyph, and glyphs not present in the message are simply not encoded. However, in order to be able to recover the information, no bit pattern that encodes a glyph is allowed to be the prefix of any other encoding bit pattern. This allows the encoded bitstream to be read bit by bit, and whenever a set of bits is encountered that represents a glyph, that glyph can be decoded. If the prefix-free constraint was not enforced, then such a decoding would be impossible.

Consider the text “AAAAABCD”. Using ASCII, encoding this would require 64 bits. If, instead, we encode “A” with the bit pattern “00”, “B” with “01”, “C” with “10”, and “D” with “11” then we can encode this text in only 16 bits; the resulting bit pattern would be “0000000000011011”. This is still a fixed-length encoding, however; we’re using two bits per glyph instead of eight. Since the glyph “A” occurs with greater frequency, could we do better by encoding it with fewer bits? In fact we can, but in order to maintain a prefix-free encoding, some of the other bit patterns will become longer than two bits. An optimal encoding is to encode “A” with “0”, “B” with “10”, “C” with “110”, and “D” with “111”. (This is clearly not the only optimal encoding, as it is obvious that the encodings for B, C and D could be interchanged freely for any given encoding without increasing the size of the final encoded message.) Using this encoding, the message encodes in only 13 bits to “0000010110111”, a compression ratio of 4.9 to 1 (that is, each bit in the final encoded message represents as much information as did 4.9 bits in the original encoding). Read through this bit pattern from left to right and you’ll see that the prefix-free encoding makes it simple to decode this into the original text even though the codes have varying bit lengths.

As a second example, consider the text “THE CAT IN THE HAT”. In this text, the letter “T” and the space character both occur with the highest frequency, so they will clearly have the shortest encoding bit patterns in an optimal encoding. The letters “C”, “I’ and “N” only occur once, however, so they will have the longest codes.

There are many possible sets of prefix-free variable-length bit patterns that would yield the optimal encoding, that is, that would allow the text to be encoded in the fewest number of bits. One such optimal encoding is to encode spaces with “00”, “A” with “100”, “C” with “1110”, “E” with “1111”, “H” with “110”, “I” with “1010”, “N” with “1011” and “T” with “01”. The optimal encoding therefore requires only 51 bits compared to the 144 that would be necessary to encode the message with 8-bit ASCII encoding, a compression ratio of 2.8 to 1. 
InputThe input file will contain a list of text strings, one per line. The text strings will consist only of uppercase alphanumeric characters and underscores (which are used in place of spaces). The end of the input will be signalled by a line containing only the word “END” as the text string. This line should not be processed. 
Output
            For each text string in the input, output the length in bits of the 8-bit ASCII encoding, the length in bits of an optimal prefix-free variable-length encoding, and the compression ratio accurate to one decimal point. 
Sample Input
AAAAABCD
THE_CAT_IN_THE_HAT
END
Sample Output
64 13 4.9
144 51 2.8
#include <string>
#include <algorithm>



using namespace std;

int num[27];

void init()
{
    int i;
    for(i = 0; i < 27; i ++){
        num[i] = 0;
    }
}

int fun()
{
    int n = 0,i,j,l;
    sort(num, num+27);
    
    int tmp[27],k = 0;
    for(i = 0; i < 27; i ++){
        if(num[i] != 0)break;
    }//找到第一个等于1的位置
    
    
    l = 27-i;//表示在第一个等于1的位置后面还有l个位置要考虑
    
    if(l == 1)return num[26];//表示考虑到最后一个了,可以输出了
    //num[i]保存的到这个一个数为止最小的哈弗曼编码的长度*8;
    
    for(i = 27-l; i < 27; i ++){
        tmp[k++] = num[i];//利用k和tmp数组来暂时保存数字,
        //      printf("tmp[%d] = %d\n", k-1, tmp[k-1]);
    }
    
    for(i = 0; i < l - 1; i ++){//考虑l个数字
        if(i%2==0){//如果偶数,则右子树
            num[0] = tmp[0] + tmp[1];
            n+=num[0];
            for(j = 2; j < k; j ++){//遍历剩下的tmp保存的原始数
                num[j-1] = tmp[j];//往前移动一个位置
            }
            k--;
            sort(num, num+k);//将新结果再进行排序
        }
        else{
            tmp[0] = num[0]+num[1];//如果为奇数,则我们保存到tmp数组中,
            n+=tmp[0];
            for(j = 2; j < k; j ++){
                tmp[j-1] = num[j];
            }
            k--;
            sort(tmp, tmp+k);
        }
    }
    
    //通过以上的奇数偶数已经tmp和num的互相协作,就可以让n不断的加入哈弗曼编码的位数
    //如果两者相加,然后从0 1变成00 01,我们知道num和tmp记录的是个数,相加后,比如
    //00 01与另外一边的1结合,会自动合成000 011 11,n通过num和tmp加上去
    return n;
}

char str[1001];

int main()
{
    
    
    
    freopen("/Users/qigelaodadehongxiaodi/Desktop/data1.txt", "r", stdin);
    //这个不理,是用来方便输入输出的东西,利用文本输入流来读取数据
    //提交代码的时候记得注销这条语句
    
    int len,i;
    int original, now;//表示原始长度以及变成哈弗曼编码的长度
    while(scanf("%s", str)&&strcmp(str,"END")!=0){
        init();
        len = strlen(str);
        for(i = 0; i < len; i ++){
            if(str[i]-'A'<26){
                num[str[i]-'A'] ++;
            }
            else {
                num[26] ++;
            }
        }//存储字符的个数
        original = 8*len;
        now = fun();
        printf("%d %d %.1lf\n", original, now, 1.0*original/now);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

m0_72429728

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值