Flow Problem hdu 3549 网络流模板题目

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 6245    Accepted Submission(s): 2916


 

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

 

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

 

Case 1: 1
Case 2: 2

Author

HyperHexagon

Source

HyperHexagon's Summer Gift (Original tasks)

直接套上然后改模板就是了

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
#define M 0x3f3f3f3f
int n,m,map[300][300],flow[300][300],p[300],a[300];

int EK_max_flow(int s,int t)
{
    int sum=0;
    int i,j;
    queue<int>q;
    memset(flow,0,sizeof(flow));
    while(true)//当找不出其他增广路线
    {

        memset(a,0,sizeof(a));//记住残余水量
        a[s]=M;
        q.push(s);
        while(!q.empty())
        {

            int u=q.front();
            q.pop();
            for(i=2;i<=m;i++)
            {
                if(!a[i]&&map[u][i]>flow[u][i])
                {
                    p[i]=u;
                    q.push(i);
                    a[i]=a[u]<map[u][i]-flow[u][i]?a[u]:map[u][i]-flow[u][i];

                }
            }


        }


           if(!a[t])//为0时离开
            break;
            for(i=t;i!=s;i=p[i])
            {
                flow[p[i]][i]+=a[t];
                flow[i][p[i]]-=a[t];
            }
            sum=sum+a[t];





    }







    return sum;


}
int main()
{

    int i,j,k;
    int a,b,c;
    int T,e=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        memset(map,0,sizeof(map));
        memset(p,0,sizeof(p));//记住每个点的父类是谁
        while(n--)
        {
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=map[a][b]+c;
        }

        int max=EK_max_flow(1,m);
        printf("Case %d: %d\n",e,max);
        e++;



    }






}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

枫叶思念

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值