模拟散列表—哈希表—拉链法;

 

输入样例:

5
I 1
I 2
I 3
Q 2
Q 5

输出样例:

Yes
No
#include<bits/stdc++.h>
using namespace std;
const int N = 1e5 + 3;
int h[N], e[N], ne[N], idx;
void insert(int x) {
	int k = (N + x % N) % N;
	e[idx] = x;
	ne[idx] = h[k];
	h[k] = idx++;
}
bool find(int x) {
	int k = (N + x % N) % N;
	for (int i = h[k];i != -1;i = ne[i]) {
		int j = e[i];
		if (j == x) {
			return true;
		}
	}
	return false;
}
int main() {
	int n;
	cin >> n;
	memset(h, -1, sizeof h);
	while (n--) {
		int x;
		char op;
		cin >> op;
		cin >> x;
		if (op == 'I') {
			insert(x);
		}
		else {
			if (find(x)) {
				cout << "Yes" << endl;
			}
			else cout << "No" << endl;
		}
	}
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ou_fan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值