Vacations dp动态规划题目

Vacations

题面翻译

Vasya 有 n n n 天的假期,每天有四种选择:

  • 在这一天,健身房关闭,比赛不进行,表示为 0 0 0

  • 在这一天,健身房关闭,比赛进行,表示为 1 1 1

  • 在这一天,健身房是开放的,比赛不进行,表示为 2 2 2

  • 在这一天,健身房是开放的,比赛是进行的,表示为 3 3 3

在每一天,Vasya 可以休息、比赛 (如果在这一天进行),或者做运动 (如果健身房在这一天是开放的)。

但 Vasya 不想连续两天做同样的活动,这意味着,他不会连续两天做运动,也不会在连续两天写比赛。

找出 Vasya 休息的最少天数。

1 ≤ n ≤ 100 1\le n\le 100 1n100 0 ≤ a i ≤ 3 0\le a_i\le 3 0ai3

题目描述

Vasya has $ n $ days of vacations! So he decided to improve his IT skills and do sport. Vasya knows the following information about each of this $ n $ days: whether that gym opened and whether a contest was carried out in the Internet on that day. For the $ i $ -th day there are four options:

  1. on this day the gym is closed and the contest is not carried out;
  2. on this day the gym is closed and the contest is carried out;
  3. on this day the gym is open and the contest is not carried out;
  4. on this day the gym is open and the contest is carried out.

On each of days Vasya can either have a rest or write the contest (if it is carried out on this day), or do sport (if the gym is open on this day).

Find the minimum number of days on which Vasya will have a rest (it means, he will not do sport and write the contest at the same time). The only limitation that Vasya has — he does not want to do the same activity on two consecutive days: it means, he will not do sport on two consecutive days, and write the contest on two consecutive days.

输入格式

The first line contains a positive integer $ n $ ( $ 1<=n<=100 $ ) — the number of days of Vasya’s vacations.

The second line contains the sequence of integers $ a_{1},a_{2},…,a_{n} $ ( $ 0<=a_{i}<=3 $ ) separated by space, where:

  • $ a_{i} $ equals 0, if on the $ i $ -th day of vacations the gym is closed and the contest is not carried out;
  • $ a_{i} $ equals 1, if on the $ i $ -th day of vacations the gym is closed, but the contest is carried out;
  • $ a_{i} $ equals 2, if on the $ i $ -th day of vacations the gym is open and the contest is not carried out;
  • $ a_{i} $ equals 3, if on the $ i $ -th day of vacations the gym is open and the contest is carried out.

输出格式

Print the minimum possible number of days on which Vasya will have a rest. Remember that Vasya refuses:

  • to do sport on any two consecutive days,
  • to write the contest on any two consecutive days.

样例 #1

样例输入 #1

4
1 3 2 0

样例输出 #1

2

样例 #2

样例输入 #2

7
1 3 3 2 1 2 3

样例输出 #2

0

样例 #3

样例输入 #3

2
2 2

样例输出 #3

1

提示

In the first test Vasya can write the contest on the day number 1 and do sport on the day number 3. Thus, he will have a rest for only 2 days.

In the second test Vasya should write contests on days number 1, 3, 5 and 7, in other days do sport. Thus, he will not have a rest for a single day.

In the third test Vasya can do sport either on a day number 1 or number 2. He can not do sport in two days, because it will be contrary to the his limitation. Thus, he will have a rest for only one day.

题解

DP!!!
因为每一天都有3种情况,所以我们有dp[i][j]为第i天的时候做第j种运动。(j=0为休息,1为比赛,2为健身)
在这里插入图片描述

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <cstring>
typedef long long ll;
using namespace std;
int n, a[110],dp[110][3];
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
	} //dp[i][0~2]  第i天 0代表休息 1代表打比赛 2代表运动
	memset(dp, 0x3f, sizeof(dp));
	dp[0][0] = dp[0][1] = dp[0][2] = 0;
	for (int i = 1; i <= n; i++) {
		dp[i][0] = min(min(dp[i][0], dp[i - 1][0]), min(dp[i - 1][1], dp[i - 1][2])) + 1;		
		if (a[i] == 1 || a[i] == 3) { 
			dp[i][1] = min(dp[i - 1][0], dp[i - 1][2]); 
		}
		if (a[i] == 2 || a[i] == 3) {
			dp[i][2] = min(dp[i - 1][0], dp[i - 1][1]);
		}
	}
	int ans = min(dp[n][0], min(dp[n][1], dp[n][2]));
	cout << ans << endl;
	return 0;
}
  • 21
    点赞
  • 16
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值