L2-008 最长对称子串
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?
,最长对称子串为s PAT&TAP s
,于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:
Is PAT&TAP symmetric?
输出样例:
11
#include<bits/stdc++.h>
using namespace std;
using ll = long long;
int Manacher(string s) {
string res = "$#";
for (int i = 0; i < s.size(); i++) {
res += s[i];
res += "#";
}
res += "@";
vector<int> p(res.size(), 0);
int mi = 0, right = 0;
int maxlen = 0, maxpoint = 0;
for (int i = 1; i < res.size(); i++) {
p[i] = right > i ? min(p[2 * mi - i], right - i) : 1;
while (res[i + p[i]] == res[i - p[i]]) p[i]++;
if (right < i + p[i]) {
right = i + p[i];
mi = i;
}
if (maxlen < p[i]) {
maxlen = p[i];
maxpoint = i;
}
}
return maxlen - 1;
}
int main(){
cout.sync_with_stdio(false);
cout.tie(nullptr);
string s;
getline(cin,s);
cout<<Manacher(s);
}