7-35 字符串循环左移
分数 20
作者 白洪欢
单位 浙江大学
输入一个字符串和一个非负整数N,要求将字符串循环左移N次。
输入格式:
输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。
输出格式:
在一行中输出循环左移N次后的字符串。
输入样例:
Hello World!
2
输出样例:
llo World!He
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<string>
#include<cctype>
#include<cmath>
#include<algorithm>
#include<set>
#include<map>
//#include<bits/stdc++.h>
using namespace std;
string s;
string temp;
int main()
{
int n;
getline(cin, s);
int length = s.size();
cin >> n;
n %= length;
Method 1:(Direct output)
printf("%s", &s[n]);
for (int i = 0; i < n; i++)
{
putchar(s[i]);
}
Method 2:(Deal string)
temp = s.substr(0, n);
s.erase(0, n);
s.insert(s.size(), temp);
return 0;
}