Problem T: 二进制数转换为十进制数

Problem Description

题目很简单,就是把一个二进制数转换为十进制数,然后输出。

Input Description

多组测试数据,第一行一个正整数 n (n<=1000),表示后面有 n 组测试数据,每组一行。
接下来有 n 行,每行为一个不超过32位的二进制数。

Output Description

对每组测试数据,在一行中输出对应的十进制数。

Sample Input

2
0111
1111

Sample Output

7
15
#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
    int n;
    scanf("%d",&n);
    for(int i = 0; i < n; i++)
    {
        char a[33], b[33];
        scanf("%s", a);
        int len;
        int c = 0;
        len = strlen(a);
        for(int i = 0; i < len; i++)
        {
            b[i] = a[i] - '0';
            if(b[i] == 1)
                c = c + pow(2,len - 1 - i);

        }
        if(i == n - 1)
        printf("%d",c);
        else
            printf("%d\n",c);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值