POJ3617-Cow_Line

Description:

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input:

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output:

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input:

6

ACDBCB

Sample Output:

ABCBCD

 

思路:

1.  要想得到字典序最小的序列,我们只需要采取贪心策略,每次将给定字符串首字母和末字母中较小的那个拿出来打印就可以了。

2.  如果首字母和末字母的字典序是一样的,那么我们同时移动两个两个比较的字母,比较第二个和倒数第二个字母的字典序。以此类推,直到两边比较出来字典序的大小,然后把字典序小的那一边的头或者尾字母打印出来(可以理解为,我们想让小字典序的字母尽快暴露出来,所以在头和尾相同的情况下,拿走了更靠近小字典序的那个字母)。

这一步同样可以理解为将原字符串与完全逆序字符串的字典序作比较,将较小字典序的头字母取出来打印,效果是一样的(因为字典序的比较始终是自头向尾的)。

3.  如果剩下的字符串是完全对称的,那么先取出哪个就无关紧要了。

Code: 

#include<iostream>
using namespace std;

int num;
char s[10001];

void solution() {
    cin >> num;
    for (int i = 0;i < num;i++)
        cin >> s[i];
    
    //用a,b两个值来控制改变的string的长度
    int a = 0;//the head of that string
    int b = num - 1;//the tail of that string
    while (a <= b) {
        bool left = false;
        for (int i = 0;a + i <= b - i;i++) {
            if (s[a + i] < s[b - i]) {
                left = true;
                break;
            }
            else if (s[a + i] > s[b - i]) {
                left = false;
                break;
            }
        }
        if (left)//如果字符串左端的字典序比较小
            putchar(s[a++]);
        else//反之
            putchar(s[b--]);
    }
    return;
}

int main() {
    solution();
    return 0;
}

  • 20
    点赞
  • 20
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值