PTA数据结构练习题——树与二叉树(并查集)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

输入样例:

2
5 3
1 2
2 3
4 5

5 1
2 5

输出样例:

2

参考代码:

#include <stdio.h>

int pre[1010];
int find(int x);

int find(int x) //函数题。涉及并查集知识。此处是并查集的查询。
{
    if (pre[x] != x)  //如果父节点不是自己,也就是x不是根,那就递归查询。
        pre[x] = find(pre[x]);
    return pre[x];  //找到父节点
}

int main()
{
    int t;
    scanf("%d", &t);

    while (t--) {
        int n, m;
        scanf("%d%d", &n, &m);
        for (int i = 1; i <= n; i++)
            pre[i] = i;

        for (int i = 0; i < m; i++) {
            int x, y;
            scanf("%d%d", &x, &y);

            int fx = find(x);
            int fy = find(y);

            if (fx != fy) pre[fx] = fy;  //并查集的合并
        }

        int cnt = 0;
        for (int i = 1; i <= n; i++)
            if (pre[i] == i) cnt++;
        printf("%d\n", cnt);
    }

    return 0;
}

  • 12
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

宇宙中的一只羊

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值