L2-012 关于堆的判断(堆的性质)

1.题目

L2-012 关于堆的判断
分数 25

全屏浏览

切换布局
作者 陈越
单位 浙江大学
将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

2.分析

        

看这道题之前要先理解怎么建堆

        这道题考察堆的知识点,堆可以用数组存储。

        (1)i>1的结点,其父结点为i/2

        (2)如果结点有孩子,那么他的左孩子是2i,右孩子是2i+1

        然后就是判断输入的命题是哪一种(我这里就暴力if)

3.代码

        

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
const int MAX=1010;
int N,M,arr[MAX];
string str;
int main(){
    cin>>N>>M;
    for(int i=1;i<=N;i++){
        cin>>arr[i];                     
        int id=i;                       //利用堆的性质建堆
        while(id>1&&arr[id]<arr[id/2]){
            swap(arr[id],arr[id/2]);
            id=id/2;
        }
    }
    getchar();
    for(int j=0;j<M;j++){
        getline(cin,str);
        if(str.find("root")!=string::npos){      //判断第一个命题
            int i=0;
            string root;
            while(str[i]!=' '){
                root+=str[i];
                i++;
            }
            if(stoi(root)==arr[1]) cout<<"T"<<endl;    //判断是否为根
            else cout<<"F"<<endl;
        }
        else if(str.find("siblings")!=string::npos){  //判断第二个命题
            int i=0;
            string x,y;
            while(str[i]!=' '){         //找第一个数
                x+=str[i];
                i++;
            }
            i=i+5;
            while(str[i]!=' '){         //找第二个数
                y+=str[i];
                i++;
            }
            int f,f1;
            for(int k=1;k<=N;k++){
                if(arr[k]==stoi(x)) f=k;
                if(arr[k]==stoi(y)) f1=k;
            }
            if(arr[f/2]==arr[f1/2]) cout<<"T"<<endl;  //判断二者关系是否为兄弟
            else cout<<"F"<<endl;
        }
        else if(str.find("parent")!=string::npos){   //判断第三个命题
            int i=0;
            string x,y;
            while(str[i]!=' '){            //找第一个数
                x+=str[i];
                i++;
            }
             i=i+18;
            while(str[i]!=' '&&i<str.size()){       //找第二个数
                y+=str[i];
                i++;
            }
            int f,f1;
            for(int k=1;k<=N;k++){
                if(arr[k]==stoi(x)) f=k;
                if(arr[k]==stoi(y)) f1=k;
            }
            if(f==f1/2) cout<<"T"<<endl;          //判断二者关系是否为父子
            else cout<<"F"<<endl;
        } 
        else if(str.find("child")!=string::npos){    //判断第四个命题
            int i=0;
            string x,y;         
            while(str[i]!=' '){           //找第一个数
                x+=str[i];
                i++;
            }
             i=i+15;
            while(str[i]!=' '&&i<str.size()){    //找第二个数
                y+=str[i];
                i++;
            }
            int f,f1;
            for(int k=1;k<=N;k++){
                if(arr[k]==stoi(x)) f=k;
                if(arr[k]==stoi(y)) f1=k;
            }
            if(f/2==f1) cout<<"T"<<endl;         //判断二者关系是否为父子
            else cout<<"F"<<endl;
        }
    }
    return 0;
}

  • 16
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值