PTA 团体程序设计天梯赛-练习集 L2-012 关于堆的判断 (25分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
注意一点: 题目要求是按照 "给定数字顺序插入堆中",不要像我一样先把数据存到一个数组里面,然后才构建的堆。
    -(但这样构建出的堆和按照顺序构建出来的是不同的)


堆的构建:
    1. 按照顺序插入: 直接将新的元素放到数组的最后,然后up即可
    2. 按照数组内容通过down来构建堆:从数组下标[1,n/2]之间的元素

void up(int u)
{
    int t = u;
    if (u/2 && heap[u/2] > heap[u]) t = u/2;
    if (t != u){
        swap(heap[t],heap[u]);
        up(t);
    }
}

void down(int u)
{
    int t = u;
    if (u * 2 <= size && h[u * 2] < h[u]) t = u * 2;
    if (u * 2 + 1 <= size && h[u * 2 + 1] < h[u]) t = u * 2 + 1;
    if (u != t)
    {
        heap_swap(u, t);
        down(t);
    }
}
#include<cstring>
#include<cstdio>
#include<iostream>
#include<map>
using namespace std;

int sz = 1,n,m;
map<int,int> hashc;
int heap[1010];

void up(int u)
{
    int t = u;
    if (u/2 && heap[u/2] > heap[u]) t = u/2;
    if (t != u){
        swap(heap[t],heap[u]);
        up(t);
    }
}

int main(){
    scanf("%d%d",&n,&m);
    int x;
    for (int i = 1; i <= n; ++i){
        scanf("%d",&x);
        heap[i] = x;
        sz = i;
        up(i);
    }
    
    for(int i = 1; i <= n; ++i){
        hashc[heap[i]] = i;
        // cout<<heap[i]<<" "<<i<<endl;
    }
    
    string line;
    getline(cin,line);
    
    for (int i = 0; i < m; ++i){
        getline(cin,line);
        if (line.find("root") != line.npos){
            int d;
            char c[33];
            sscanf(line.c_str(),"%d is the root",&d,c);
            if (d == heap[1])   cout<<"T"<<endl;
            else    cout<<"F"<<endl;
        }else if(line.find("siblings") != line.npos){
            int d1,d2;
            sscanf(line.c_str(),"%d and %d are siblings",&d1,&d2);
            if (abs(hashc[d1] - hashc[d2]) == 1 && hashc[d1]/2 == hashc[d2]/2)
                cout<<"T"<<endl;
            else cout<<"F"<<endl;
        }else if(line.find("parent") != line.npos){
            int d1,d2;
            sscanf(line.c_str(),"%d is the parent of %d",&d1,&d2);
            if (2*hashc[d1] == hashc[d2] || 2*hashc[d1] + 1 == hashc[d2])
                cout<<"T"<<endl;
            else cout<<"F"<<endl;
        }else if(line.find("child") != line.npos){
            int d1,d2;
            sscanf(line.c_str(),"%d is a child of %d",&d1,&d2);
            if (2*hashc[d2] == hashc[d1] || 2*hashc[d2] + 1 == hashc[d1])
                cout<<"T"<<endl;
            else cout<<"F"<<endl;            
        }
    }
    return 0;
}

 

 

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值