hdu 1032 The 3n + 1 problem

Description

Problems in Computer Science are oftenclassified as belonging to a certain class of problems (e.g., NP, Unsolvable,Recursive). In this problem you will be analyzing a property of an algorithmwhose classification is not known for all possible inputs.

Consider the following algorithm:

1.     input n

2.     print n  

3.     if n = 1 then STOP

4.          if n is odd then n <- 3n + 1

5.          else n <- n / 2

6.     GOTO 2

Given the input 22, the following sequenceof numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm abovewill terminate (when a 1 is printed) for any integral input value. Despite thesimplicity of the algorithm, it is unknown whether this conjecture is true. Ithas been verified, however, for all integers n such that 0 < n <1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible todetermine the number of numbers printed (including the 1). For a given n thisis called the cycle-length of n. In the example above, the cycle length of 22is 16.

For any two numbers i and j you are todetermine the maximum cycle length over all numbers between i and j.

 

Input

The input will consist of a series of pairsof integers i and j, one pair of integers per line. All integers will be lessthan 1,000,000 and greater than 0.

You should process all pairs of integersand for each pair determine the maximum cycle length over all integers betweenand including i and j.

You can assume that no opperation overflowsa 32-bit integer.

 

Output

For each pair of input integers i and j youshould output i, j, and the maximum cycle length for integers between andincluding i and j. These three numbers should be separated by at least onespace with all three numbers on one line and with one line of output for eachline of input. The integers i and j must appear in the output in the same orderin which they appeared in the input and should be followed by the maximum cyclelength (on the same line).

 

Sample Input

1 10

100 200

201 210

900 1000

 

Sample Output

1 10 20

100 200 125

201 210 89

900 1000 174 

Description

Problems in Computer Science are oftenclassified as belonging to a certain class of problems (e.g., NP, Unsolvable,Recursive). In this problem you will be analyzing a property of an algorithmwhose classification is not known for all possible inputs.

Consider the following algorithm:

1.     input n

2.     print n  

3.     if n = 1 then STOP

4.          if n is odd then n <- 3n + 1

5.          else n <- n / 2

6.     GOTO 2

Given the input 22, the following sequenceof numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm abovewill terminate (when a 1 is printed) for any integral input value. Despite thesimplicity of the algorithm, it is unknown whether this conjecture is true. Ithas been verified, however, for all integers n such that 0 < n <1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible todetermine the number of numbers printed (including the 1). For a given n thisis called the cycle-length of n. In the example above, the cycle length of 22is 16.

For any two numbers i and j you are todetermine the maximum cycle length over all numbers between i and j.

 

Input

The input will consist of a series of pairsof integers i and j, one pair of integers per line. All integers will be lessthan 1,000,000 and greater than 0.

You should process all pairs of integersand for each pair determine the maximum cycle length over all integers betweenand including i and j.

You can assume that no opperation overflowsa 32-bit integer.

 

Output

For each pair of input integers i and j youshould output i, j, and the maximum cycle length for integers between andincluding i and j. These three numbers should be separated by at least onespace with all three numbers on one line and with one line of output for eachline of input. The integers i and j must appear in the output in the same orderin which they appeared in the input and should be followed by the maximum cyclelength (on the same line).

 

Sample Input

1 10

100 200

201 210

900 1000

 

Sample Output

1 10 20

100 200 125

201 210 89

900 1000 174 


题意:输入两个数字,将这两个数字之间的所有整数(包括输入的两个整数)进行题目所要求的运算,分别记录运算次数,将其比较,输出最大的运算次数。题目并未说明所输入的两个数的大小关系,执行操作和输出结果时都需要考虑到两数的大小关系

#include<stdio.h>
int main()
{
    int n,i,j,t,flag,max,x,y,k;
    while(~scanf("%d%d",&i,&j))
    {
        flag=1;
        if(i>j)
        {
            flag=0;
            t=i;
            i=j;
            j=t;
        }
        max=0;
        for(x=i;x<=j;x++)
        {
            y=1;
            k=x;
            while(k!=1)
            {
                if(k%2!=0)
                    k=3*k+1;
                else if(k%2==0)
                    k=k/2;
                y++;
            }
            if(y>max)
                max=y;
        }
        if(flag==0)
            printf("%d %d %d\n",j,i,max);
        else if(flag==1)
            printf("%d %d %d\n",i,j,max);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值