hdu 1076 An Easy Task

Description

Ignatius was born in a leap year, so hewant to know when he could hold his birthday party. Can you tell him?

 

Given a positive integers Y which indicatethe start year, and a positive integer N, your task is to tell the Nth leapyear from year Y.

 

Note: if year Y is a leap year, then the1st leap year is year Y.

 

Input

The input contains several test cases. Thefirst line of the input is a single integer T which is the number of testcases. T test cases follow.

Each test case contains two positiveintegers Y and N(1<=N<=10000).

 

Output

For each test case, you should output theNth leap year from year Y.

 

Sample Input

3

2005 25

1855 12

2004 10000

 

Sample Output

2108

1904

43236

 

Hint

We call year Y a leap year only if (Y%4==0&& Y%100!=0) or Y%400==0.


题意:输入一个年份,计算从输入年份开始的第几个闰年是哪一年,并输出年份。需要考虑到闰年并不是四年一次,也有可能八年一次。闰年的判断的条件:普通年份能整除4,不能整除100,以00结尾的年份能整除400。


#include<stdio.h>
int main()
{
    int t,y,n,count=0,k;
    scanf("%d",&t);
    while(t--)
    {
        count=0;
        scanf("%d%d",&y,&n);
        while(count<n)
        {
            if((y%4==0&&y%100!=0)||(y%400==0))
            {
                k=y;
                y+=4;
                count++;
            }
            else y++;
        }
        printf("%d\n",k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值