The 3n + 1 problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59031 Accepted Submission(s): 21422
Problem DescriptionProblems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:
1. input n
2. print n
3. if n = 1 then STOP
4. if n is odd then n <- 3n + 1
5. else n <- n / 2
6. GOTO 2
Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)
Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.
For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.InputThe input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
You can assume that no opperation overflows a 32-bit integer.OutputFor each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).Sample Input
1 10100 200201 210900 1000Sample Output1 10 20100 200 125201 210 89900 1000 174
这题..这题其实 虽然很长的英文 但是题意还是很好理解的 我做出来也比较快 但是一开始一直TLE后面一直WA
这题有个坑 就是i不一定小于等于j 也有可能大于j 所以当i>j的时候要交换他们的值 但是又要注意后面输出的时候要输出没有交换前的i和j
这个真的没有考虑到 感觉再给自己四个小时也想不到这一点 ..
下面放一下ac代码:
#include<iostream>
int fun(int n)//返回循环长度
{
int num=1;
while(n!=1)
{
if(n%2!=0)
{
n=3*n+1;
num++;
}
else
{
n=n/2;
num++;
}
}
return num;
}
int main()
{
using namespace std;
int i,j;
int m,n;
while(scanf("%d%d",&i,&j)!=EOF)
{
cout<<i<<' '<<j<<' ';//这里的输出必须放在前面
if(i>j)
{
int temp;
temp=i;
i=j;
j=temp;
}
int max=0;
int maxlen=0;
for(int k=i;k<=j;k++)
{
if(fun(k)>maxlen)
{
max=k;
maxlen=fun(k);
}
}
cout<<maxlen<<endl;
}
return 0;
}