HDU - 1560----DNA sequence

The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example,given”ACGT”,”ATGC”,”CGTT” and “CAGT”, you can make a sequence in the following way. It is the shortest but may be not the only one.

这里写图片描述

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.

Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.

Sample Input
1
4
ACGT
ATGC
CGTT
CAGT
Sample Output
8

题目大意:题意就是给出N个长度不定的DNA序列,要求出一个包含这n个序列的最短序列是多长
思路:用到迭代加深搜索—–>可以参考我的这篇 非启发式搜索

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std; 
const int N=8;

char str[N][5];
int n,ans,depth,size[N];//限制深度
char DNA[] = {'A','G','C','T'};

void DFS(int tier,int len[]){ 
    int temLen = 0;//预计还要匹配的字符串的最大长度为未匹配到的字符串长度最 
    for(int i=0 ; i<n ; i++){  
        if(size[i]-len[i] > temLen){
            temLen = size[i]-len[i]; 
        }
    }
    if(temLen == 0){//不需要匹配说明已找到 
        ans = tier;
        return;
    }
    if(tier+temLen > depth){//预计的层+已经搜的层>限制深度,停止搜索
        return;
    }

    for(int i=0 ; i<4 ; i++){
        int newLen[10];
        bool flag = false;  
        for(int j=0 ; j<n ; j++){  
            if(str[j][len[j]] == DNA[i]){//匹配到一个  
                flag = true;  
                newLen[j] = len[j]+1;//更新匹配长度  
            }else{
                newLen[j] = len[j];  
            } 
        } 
        if(flag){//没有更新匹配长度说明此情况以搜索过 
            DFS(tier+1,newLen);
        }
        if(ans != 0){//已找到答案,停止搜索 
            break;
        }
    }
}

int main(void){
    int c;
    cin>>c;

    while(c--){
        cin>>n;
        depth=0;//初始限制深度 
        for(int i=0 ; i<n ; i++){
            cin>>str[i];
            size[i] = strlen(str[i]);
            if(size[i] > depth){//初始限制深度为最长的字符串长度 
                depth = size[i];
            }
        }

        int len[N]={0};//记录了n个字符串已经匹配到的位置 
        ans = 0; 

        while(true){
            DFS(0,len);
            if(ans == 0){
                depth++;//如过没有找到答案,则搜索加深一层 
            }else{
                cout<<ans<<endl;
                break;
            }   
        }
    }

    return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值