UVa 232 Crossword Answers

UVa 232 Crossword Answers


A crossword puzzle consists of a rectangular grid of black and whitesquares and two lists of definitions (or descriptions).

One list of definitions is for ``words" to be written left to rightacross white squares in the rows and the other list is for words to be writtendown white squares in the columns. (A word is a sequence of alphabeticcharacters.)

To solve a crossword puzzle, one writes the words corresponding to thedefinitions on the white squares of the grid.

The definitions correspond to the rectangular grid by means of sequentialintegers on ``eligible" white squares. White squares with black squaresimmediately to the left or above them are ``eligible." White squares withno squares either immediately to the left or above are also ``eligible."No other squares are numbered. All of the squares on the first row arenumbered.

The numbering starts with 1 and continues consecutively across whitesquares of the first row, then across the eligible white squares of the secondrow, then across the eligible white squares of the third row and so on acrossall of the rest of the rows of the puzzle. The picture below illustrates arectangular crossword puzzle grid with appropriate numbering.

An ``across" word for a definition is written on a sequence of whitesquares in a row starting on a numbered square that does not follow anotherwhite square in the same row.

The sequence of white squares for that word goes across the row of thenumbered square, ending immediately before the next black square in the row orin the rightmost square of the row.

A ``down" word for a definition is written on a sequence of whitesquares in a column starting on a numbered square that does not follow anotherwhite square in the same column.

The sequence of white squares for that word goes down the column of thenumbered square, ending immediately before the next black square in the columnor in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles asinput and outputs the lists of across and down words which constitute thesolutions.


Input

Each puzzle solution in the input starts with a line containing twointegersr and c ( 1<r<10 and 1<c<10 ), where r(the first number) is the number of rows in the puzzle andc (the secondnumber) is the number of columns.

The r rows of input which follow each containc characters(excluding the end-of-line) which describe the solution. Each of thoseccharacters is an alphabetic character which is part of a word or the character``*", which indicates a black square.

The end of input is indicated by a line consisting of the single number 0.


Output

Output for each puzzle consists of an identifier for the puzzle (puzzle#1:, puzzle #2:, etc.) and the list of across words followed by the list ofdown words. Words in each list must be output one-per-line in increasing orderof the number of their corresponding definitions.

The heading for the list of across words is ``Across". The headingfor the list of down words is ``Down".

In the case where the lists are empty (all squares in the grid are black),the Across and Down headings should still appear.

Separate output for successive input puzzles by a blank line.


Sample Input

2 2

AT

*O

6 7

AIM*DEN

*ME*ONE

UPON*TO

SO*ERIN

*SA*OR*

IES*DEA

0


Sample Output

puzzle #1:

Across

  1.AT

  3.O

Down

  1.A

  2.TO

 

puzzle #2:

Across

  1.AIM

  4.DEN

  7.ME

  8.ONE

  9.UPON

 11.TO

 12.SO

 13.ERIN

 15.SA

 17.OR

 18.IES

 19.DEA

Down

  1.A

  2.IMPOSE

  3.MEO

  4.DO

  5.ENTIRE

  6.NEON

  9.US

 10.NE

 14.ROD

 16.AS

 18.I

 20.A

 


代码:

<p><span style="font-size:14px;">#include<stdio.h>
#include<string.h>
int p=0,r,c,f[1000];
char s[15][15],down[10000][15];
void Lookline(int i,int j,int *t)
{
	int q=1,x=i;
	down[p][0]=*t;
	if(s[x-1][j]=='*'||x==0)
	{	
		while(x<r)
			{
				if(s[x][j]=='*') break;
				down[p][q++]=s[x++][j];
			}
		down[p][q]='1';
		if(s[i][j-1]=='*'||j==0) ;
		else (*t)++;
	} 
	p++,
	x=j;	
	if((s[i][j-1]=='*'||j==0))
	{
		printf("%3d.",*t);
		while(x<c)
		{
			if(s[i][x]=='*') break;		
			printf("%c",s[i][x++]);
		}
		(*t)++;printf("\n");
	}
}
int main()
{
	memset(s,0,sizeof(s));
	int i,j,t,x=0,f=0;
	while(scanf("%d",&r)!=EOF)
	{
		
		if(r==0) break;
		
		scanf("%d",&c);
		getchar();
		for(i=0;i<r;i++)
			gets(s[i]);
		t=1,p=0;if(f) printf("\n");
		memset(down,0,sizeof(down));
		printf("puzzle #%d:\n",++f);
		printf("Across\n");
		for(i=0;i<r;i++)
			for(j=0;j<c;j++)
			{
				if(s[i][j]!='*')				
					Lookline(i,j,&t);
			} 
		
		printf("Down\n");
		for(i=0;i<p;i++)
		{	
			x=0;	
			if(down[i][1]) printf("%3d.",down[i][0]);
			for(j=1;down[i][j]!='1'&&down[i][j];j++)
			{		
				x=1;
				printf("%c",down[i][j]);
			}					
			if(x) printf("\n");
		}
	}
	return 0;
} 
</span></p>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值