Aggressive cows 二分

Aggressive cows
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

  • Line 1: Two space-separated integers: N and C
  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output
  • Line 1: One integer: the largest minimum distance
    Sample Input
    5 3
    1
    2
    8
    4
    9
    Sample Output
    3
    Hint
    OUTPUT DETAILS:
    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
    Huge input data,scanf is recommended.
    题目大意:
    FJ有一个有n间牛棚的小屋,牛棚在一条直线上,坐标为分别为x[i],但是他的c头牛对牛棚不满,因此会经常相互攻击,FJ为了防止牛之间相互攻击,决定把每头牛都放在离其他牛尽可能远的牛棚中,也就是要最大化最近两头牛之间的距离。

思路:
1.安排牛的位置使得最近两头牛的距离为d。
2.那么问题就变为了求C(d)的最大值的d,另外,最近的两头牛的距离不小于d。
3.就是说C(d)=可以安排牛的位置使得任意两头牛的距离都不小于d。
4.判断要找的值是小于X的最大值(left)还是大于x的最小值(right)
5.显然本题找的是小于x的最大值。

在这里插入图片描述

红的是隔间,灰色的是奶牛

#include<cstdio>
#include<iostream>
#include<algorithm> 
#define maxn 1000000
typedef long long ll;
using namespace std;
ll n,c;
ll a[maxn];
bool check(ll x)
{
	ll ff=a[0];  //从第一个隔间开始
	ll i;
	ll sum=1;       //是两个隔间距离相减,所以如果有隔间符合要求
	                //那么初始必存在一个
	for(i=1;i<n;i++)
	{
		if(a[i]-ff>=x)   //第i个隔间减去上一个隔间距离要>=x(mid)
		{
			sum++;        //符合房间数++
			ff=a[i];       //记录上一个符合条件的房间位置
		}
	}
	if(sum>=c) return 1;   //房间数和奶牛数相等 yes!
	else return 0;        //不相等  no!
}
int main()
{
	
	cin>>n>>c;

	ll i;
	for(i=0;i<n;i++)
	{
		cin>>a[i];
	}
	sort(a,a+n); //排序
	ll mid;
	ll l=0,r=a[n-1]-a[0];   //边界
	while(r-l>1)  //要右边界>左边界         
	{
		mid=(l+r)/2;  //  取中间值
		if(check(mid))   判断yes的话
        l=mid;      //   左值++(向右移动)
		else
		r=mid;			//右值--(向左移动)
	}
	cout<<l;         //最小的最大
	return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值