[HYSBZ - 1734] Aggressive cows 愤怒的牛(二分)

17 篇文章 0 订阅
10 篇文章 0 订阅

1734: [Usaco2005 feb]Aggressive cows 愤怒的牛

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000)stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括N(2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,…,xN (0<= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢?

Input

Line 1: Two space-separated integers: N and C
Lines 2…N+1: Line i+1 contains an integer stall location, xi
第一行:空格分隔的两个整数N和C
第二行—第N+1行:i+1行指出了xi的位置

Output

Line 1: One integer: the largest minimum distance
第一行:一个整数,最大的最小值

Sample Input

5 3
1
2
8
4
9

Sample Output

3

(把牛放在1,4,8这样最小距离是3)

解析
牛分开放置且最小距离最大,求这个距离。

先把所有的位置按顺序排序好,再把牛放进去。为了求这个最大的最小距离,我们假设一个距离x并尝试将牛一头头放进去(两头牛距离大于或等于x),直到所有牛能放完(满足最小距离)。如果牛不能放完说明距离过大,反则距离过小,不断调整距离x我们就可以得到所求距离。

由以上思路分析来看,此题可以用二分法的思想求解。

C++代码(C代码请跳至文章末)

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int a[100005];
int main(void)
{
    int n,c;
    scanf("%d%d",&n,&c);
    int i,cnt,j;
    for(i=0;i<n;i++)
        scanf("%d",&a[i]);
    sort(a,a+n);	//排序
    long long l=0,r=a[n-1],mid;
    while(l<r)		//二分开始
    {
        cnt=1;
        mid=(l+r+1)/2;
        int last=0,next=1;
        for(;next<n;next++)	
            if(a[next]-a[last]>=mid)
            {	//两头牛的距离满足放置条件
                cnt++;
                last=next;
                if(cnt==c)
                    break;
            }
        if(cnt>=c)	//调整距离 靠近所求值
            l=mid;
        else r=mid-1;
    }
    printf("%lld\n",l);
}

emmmmmmm…
用C写的话排序(冒泡、选择)是会超时的,也许快速排序可以AC

一直超时直到有人告诉我只要换成C++的sort就可以过…

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值