noi-1745-字符串判等

字符串判等


总时间限制: 
1000ms 
内存限制: 
65536kB
描述

判断两个由大小写字母和空格组成的字符串在忽略大小写,且忽略空格后是否相等。

输入
两行,每行包含一个字符串。
输出
若两个字符串相等,输出YES,否则输出NO。
样例输入
a A bb BB ccc CCC
Aa BBbb CCCccc
样例输出
YES
//noi_1745 
#include<iostream>
#include<cstring>
#include<ctype.h>

using namespace std;

int main(){
	string s1,s2;
	string temp1,temp2;
	getline(cin,s1);
	getline(cin,s2);
	for(int i=0;i<s1.length();i++){
		if(s1[i]==' ') continue;
		temp1+=s1[i];
	}
	for(int i=0;i<s2.length();i++){
		if(s2[i]==' ') continue;
		temp2+=s2[i];
	}
	if(temp1.length()!=temp2.length()){
		cout<<"NO";
		return 0;
	}
	for(int i=0;i<s1.length();i++){
		temp1[i]=tolower(temp1[i]);
		temp2[i]=tolower(temp2[i]);
	}
	if(temp1==temp2) cout<<"YES";
	else cout<<"NO";
	return 0;
}



 
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值