数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description


已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input

输入数据有多行,每一行是一个长度小于50个字符的字符串。

Output

按从上到下从左到右的顺序输出二叉树的叶子结点。

Example Input

abd,,eg,,,cf,,,
xnl,,i,,u,,

Example Output

dfg
uli

Hint



Author

xam


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node
{
    char data;
    struct node *lc, *rc;
}*Tree;
 Tree b[55];     //一开始把*b[]放在了结构体后边,结果显示什么'['什么,我觉的应该b本身就是地址在*b导致的错误。

void OutPutLeaves(Tree T);

void creat(Tree &T);
char a[55];
int i, j, k;
Tree p;
int main()
{
    Tree T;

    while(~scanf("%s", a))
    {
        i = -1;
        j = 1;
        k = 0;
        creat(T);
        b[0] = T;
        OutPutLeaves(T);
        printf("\n");

    }
    return 0;
}

void creat (Tree &T)
{
    char c;
    c = a[++i];
    if(c == ',')
        T = NULL;
    else
    {
        T = (Tree)malloc(sizeof(struct node));
        T->data = c;
        creat(T->lc);
        creat(T->rc);
    }
}

void OutPutLeaves(Tree T)
{
  if(T)
  {
      while(k < j)// k不能小于等于j,那样就跳不出来
      {
          if(b[k]->lc == NULL &&b[k]->rc == NULL)
          {
              printf("%c", b[k] ->data);
          }
          if(b[k]->lc != NULL)
          {
              b[j] = b[k]->lc;
              j++;
          }
          if(b[k]->rc != NULL)
          {
              b[j] = b[k]->rc;
              j++;
          }
          k++;

      }
  }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值