LETTERS_POJ1154

1 篇文章 0 订阅

题目

LETTERS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8677 Accepted: 3885

Description

A single-player game is played on a rectangular board divided in R rows and C columns. There is a single uppercase letter (A-Z) written in every position in the board. 
Before the begging of the game there is a figure in the upper-left corner of the board (first row, first column). In every move, a player can move the figure to the one of the adjacent positions (up, down,left or right). Only constraint is that a figure cannot visit a position marked with the same letter twice. 
The goal of the game is to play as many moves as possible. 
Write a program that will calculate the maximal number of positions in the board the figure can visit in a single game.

Input

The first line of the input contains two integers R and C, separated by a single blank character, 1 <= R, S <= 20. 
The following R lines contain S characters each. Each line represents one row in the board.

Output

The first and only line of the output should contain the maximal number of position in the board the figure can visit.

Sample Input

3 6
HFDFFB
AJHGDH
DGAGEH

Sample Output

6

题意

从方格最左上点出发,对任意点,可以转移到其四邻域,限制为相同字符不能经过两次,找出所能经过的最多字符数。

思路

DFS。回溯思想。

细节

我做的是用set记录所经过的字符,本想着查找快速。。。然而并不快。。。

代码

标记用于传参的,代码。

#include <iostream>
#include <cstdio>
#include <set>
#include <algorithm>

using namespace std;
#define MAX_N 22
int R,C;
char maze[MAX_N][MAX_N];
int dx[] = {-1, 0, 0, 1};
int dy[] = { 0, 1,-1, 0};
int dfs(int x, int y, set<char> chSet);

int main()
{
    cin >> R >> C;
    for (int i = 0; i < R; i++) {
		getchar();
		for (int j = 0; j < C; j++) {
			scanf("%c", &maze[i][j]);
		}
    }
    set<char> chSett;
    cout << dfs(0, 0, chSett) << endl;

    return 0;
}

int dfs(int x, int y, set<char> chSet) {
	chSet.insert(maze[x][y]);
	int larger = 0;
	for (int i = 0; i < 4; i++) {
		int nx = x + dx[i], ny = y + dy[i];
		if (nx >= 0 && nx < R && ny >= 0 && ny < C && (chSet.empty() || chSet.find(maze[nx][ny]) == chSet.end())) {
			larger = max(larger, dfs(nx, ny, chSet));
		}
	}
	larger++;
	return larger;
}

修改后的AC代码

#include <iostream>
#include <cstdio>
#include <set>
#include <algorithm>

using namespace std;
#define MAX_N 22
int R,C;
char maze[MAX_N][MAX_N];
int dx[] = {-1, 0, 0, 1};
int dy[] = { 0, 1,-1, 0};
set<char> chSet;
int dfs(int x, int y);

int main()
{
    cin >> R >> C;
    for (int i = 0; i < R; i++) {
		getchar();
		for (int j = 0; j < C; j++) {
			scanf("%c", &maze[i][j]);
		}
    }
	cout << dfs(0, 0) << endl;

    return 0;
}

int dfs(int x, int y) {
	chSet.insert(maze[x][y]);
	int larger = 0;
	for (int i = 0; i < 4; i++) {
		int nx = x + dx[i], ny = y + dy[i];
		if (nx >= 0 && nx < R && ny >= 0 && ny < C && (chSet.empty() || chSet.find(maze[nx][ny]) == chSet.end())) {
			larger = max(larger, dfs(nx, ny));

		}
	}
	chSet.erase(maze[x][y]);
	larger++;
	return larger;
}

优化:

最开始的代码set传参耗时较大,故TLE。其实这个代码中用于标记已mark过的letter的数据结构还是不够好,每判断一次字符是否已mark就要用O(nlgn)时间,若用数组存储,查找时间将更快。看了一下被人题解,是化char为int这样更便于判断,mark过的数也更容易用数组存储。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值