HDU - 5916 Harmonic Value Description

HDU - 5916 Harmonic Value Description

The harmonic value of the permutation p1,p2,⋯pn is
∑i=1n−1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
Input
The first line contains only one integer T (1≤T≤100), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k (1≤2k≤n≤10000).
Output
For each test case, output one line “Case #x: p1 p2 ⋯ pn”, where x is the case number (starting from 1) and p1 p2 ⋯ pn is the answer.
Sample Input
2
4 1
4 2
Sample Output
Case #1: 4 1 3 2
Case #2: 2 4 1 3

有的题,它就是个思维题,但是这并不代表着一定就能做出来,比如这道题。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm> 
#include<cstring>
#include<string>
#define N 510
#define INF 0x3f3f3f3f
using namespace std; 

int main()
{
    int t,n,k,ans,i;
    ans=0;
    scanf("%d",&t);
    while(t--){
        ans++;
        scanf("%d%d",&n,&k);
        printf("Case #%d: ",ans);
        for(i=2;i<=k;i++){
            printf("%d ",i);
        }
        for(i=k*2;i<=n;i++){
            printf("%d ",i);
        }
        printf("1 ");
        for(i=k+1;i<=2*k-1;i++){
            printf("%d",i);
            if(i<2*k-1)
            printf(" ");
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值